]> git.pld-linux.org Git - packages/python-smmap.git/blob - python-smmap.spec
5b3f9b0ad5b558dc05da842c2bd3366ffee71c24
[packages/python-smmap.git] / python-smmap.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  smmap
6 Summary:        A pure git implementation of a sliding window memory map manager
7 # Name must match the python module/package name (as in 'import' statement)
8 Name:           python-%{module}
9 Version:        0.8.2
10 Release:        2
11 License:        BSD
12 Group:          Development/Languages/Python
13 Source0:        http://pypi.python.org/packages/source/s/smmap/%{module}-%{version}.tar.gz
14 # Source0-md5:  f5426b7626ddcf5e447253fae0396b0c
15 URL:            https://github.com/Byron/smmap
16 BuildRequires:  python-distribute
17 BuildRequires:  rpm-pythonprov
18 # if py_postclean is used
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 Requires:       python-modules
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A pure git implementation of a sliding window memory map manager.
26
27 %prep
28 %setup -q -n %{module}-%{version}
29
30 %build
31 %py_build
32
33 %{?with_tests:%{__python} setup.py test}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 %py_install
38
39 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/smmap/test
40
41 %py_postclean
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %dir %{py_sitescriptdir}/smmap
49 %{py_sitescriptdir}/smmap/*.py[co]
50 %{py_sitescriptdir}/smmap-*.egg-info
This page took 0.102613 seconds and 2 git commands to generate.