]> git.pld-linux.org Git - packages/python-smmap.git/blob - python-smmap.spec
1dd00faba89dc3ddc9af2a36b3e35110461e9e9d
[packages/python-smmap.git] / python-smmap.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  tests   # unit tests
6
7 %define         module  smmap
8 Summary:        A pure Python implementation of a sliding window memory map manager
9 Summary(pl.UTF-8):      Czysto pythonowa implementacja zarządcy odwzorowania w pamięci z przesuwnym oknem
10 Name:           python-%{module}
11 Version:        2.0.5
12 Release:        2
13 License:        BSD
14 Group:          Development/Languages/Python
15 #Source0Download: https://github.com/gitpython-developers/smmap/releases
16 Source0:        https://github.com/gitpython-developers/smmap/archive/v%{version}/%{module}-%{version}.tar.gz
17 # Source0-md5:  e20f277aa4d654c85383d582c6339eb6
18 URL:            https://github.com/gitpython-developers/smmap
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-nose
24 BuildRequires:  python-nosexcover
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules >= 1:3.4
29 BuildRequires:  python3-setuptools
30 %if %{with tests}
31 BuildRequires:  python3-nose
32 BuildRequires:  python3-nosexcover
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 Requires:       python-modules
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A pure Python implementation of a sliding window memory map manager.
43
44 %description -l pl.UTF-8
45 Czysto pythonowa implementacja zarządcy odwzorowania w pamięci z
46 przesuwnym oknem.
47
48 %package -n python3-%{module}
49 Summary:        A pure Python implementation of a sliding window memory map manager
50 Summary(pl.UTF-8):      Czysto pythonowa implementacja zarządcy odwzorowania w pamięci z przesuwnym oknem
51 Group:          Development/Languages/Python
52 Requires:       python3-modules >= 1:3.4
53
54 %description -n python3-%{module}
55 A pure Python implementation of a sliding window memory map manager.
56
57 %description -n python3-%{module} -l pl.UTF-8
58 Czysto pythonowa implementacja zarządcy odwzorowania w pamięci z
59 przesuwnym oknem.
60
61 %prep
62 %setup -q -n %{module}-%{version}
63
64 %build
65 %if %{with python2}
66 %py_build %{?with_tests:test}
67 %endif
68
69 %if %{with python3}
70 %py3_build %{?with_tests:test}
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %if %{with python2}
77 %py_install
78
79 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/smmap/test
80
81 %py_postclean
82 %endif
83
84 %if %{with python3}
85 %py3_install
86
87 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/smmap/test
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{with python2}
94 %files
95 %defattr(644,root,root,755)
96 %dir %{py_sitescriptdir}/smmap
97 %{py_sitescriptdir}/smmap/*.py[co]
98 %{py_sitescriptdir}/smmap2-%{version}-py*.egg-info
99 %endif
100
101 %if %{with python3}
102 %files -n python3-%{module}
103 %defattr(644,root,root,755)
104 %dir %{py3_sitescriptdir}/smmap
105 %{py3_sitescriptdir}/smmap/*.py
106 %{py3_sitescriptdir}/smmap/__pycache__
107 %{py3_sitescriptdir}/smmap2-%{version}-py*.egg-info
108 %endif
This page took 0.060955 seconds and 2 git commands to generate.