]> git.pld-linux.org Git - packages/python-sleekxmpp.git/blob - python-sleekxmpp.spec
825fb49cb3b802ebb4beecd1b4361c5a106ec56d
[packages/python-sleekxmpp.git] / python-sleekxmpp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  sleekxmpp
6 Summary:        Flexible XMPP client/component/server library for Python
7 Name:           python-%{module}
8 Version:        1.1.11
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 Source0:        http://pypi.python.org/packages/source/s/sleekxmpp/%{module}-%{version}.tar.gz
13 # Source0-md5:  95f847b64fb84483acfadce425fe42cf
14 URL:            https://github.com/fritzy/SleekXMPP
15 BuildRequires:  python-devel
16 BuildRequires:  python3-devel
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 %if %{with tests}
19 BuildRequires:  gnupg
20 %endif
21 Requires:       python-dns
22 Requires:       python-pyasn1
23 Requires:       python-pyasn1_modules
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 SleekXMPP is a flexible XMPP library for python that allows you to
29 create clients, components or servers for the XMPP protocol. Plug-ins
30 can be create to cover every current or future XEP.
31
32 %package -n python3-sleekxmpp
33 Summary:        Flexible XMPP client/component/server library for Python
34 Group:          Libraries/Python
35 Requires:       python3-dns
36
37 %description -n python3-sleekxmpp
38 SleekXMPP is a flexible XMPP library for python that allows you to
39 create clients, components or servers for the XMPP protocol. Plug-ins
40 can be create to cover every current or future XEP.
41
42 %prep
43 %setup -q -n %{module}-%{version}
44 set -- *
45 install -d py3
46 cp -a "$@" py3
47
48 %build
49 %{__python} setup.py build
50 cd py3
51 %{__python3} setup.py build
52 cd ..
53
54 %if %{with tests}
55 %{__python} testall.py
56 cd py3
57 %{__python3} testall.py
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__python} setup.py install \
63         --optimize=2 \
64         --skip-build \
65         --root $RPM_BUILD_ROOT
66
67 %py_postclean
68
69 cd py3
70 %{__python3} setup.py install \
71         --optimize=2 \
72         --skip-build \
73         --root $RPM_BUILD_ROOT
74
75 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/sleekxmpp/test
76 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/sleekxmpp/test
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc LICENSE README.rst
84 %dir %{py_sitescriptdir}/sleekxmpp
85 %{py_sitescriptdir}/sleekxmpp/*.py[co]
86 %{py_sitescriptdir}/sleekxmpp-%{version}-*.egg-info
87 %{py_sitescriptdir}/sleekxmpp/features
88 %{py_sitescriptdir}/sleekxmpp/plugins
89 %{py_sitescriptdir}/sleekxmpp/roster
90 %{py_sitescriptdir}/sleekxmpp/stanza
91 %{py_sitescriptdir}/sleekxmpp/thirdparty
92 %{py_sitescriptdir}/sleekxmpp/util
93 %{py_sitescriptdir}/sleekxmpp/xmlstream
94
95 %files -n python3-sleekxmpp
96 %defattr(644,root,root,755)
97 %doc LICENSE README.rst
98 %dir %{py3_sitescriptdir}/sleekxmpp
99 %{py3_sitescriptdir}/sleekxmpp/*.py
100 %{py3_sitescriptdir}/sleekxmpp/__pycache__
101 %{py3_sitescriptdir}/sleekxmpp/features
102 %{py3_sitescriptdir}/sleekxmpp/plugins
103 %{py3_sitescriptdir}/sleekxmpp/roster
104 %{py3_sitescriptdir}/sleekxmpp/stanza
105 %{py3_sitescriptdir}/sleekxmpp/thirdparty
106 %{py3_sitescriptdir}/sleekxmpp/util
107 %{py3_sitescriptdir}/sleekxmpp/xmlstream
108 %{py3_sitescriptdir}/sleekxmpp-%{version}-*.egg-info
This page took 0.066248 seconds and 2 git commands to generate.