]> git.pld-linux.org Git - packages/python-slacker.git/blob - python-slacker.spec
d1128ddc5787de4f70b4747c720d615a53a77aa3
[packages/python-slacker.git] / python-slacker.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  slacker
7 Summary:        Slack API client
8 Name:           python-%{module}
9 Version:        0.9.2
10 Release:        5
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 Source0:        https://pypi.python.org/packages/source/s/slacker/%{module}-%{version}.tar.gz
14 # Source0-md5:  55d089c4350b3a74d0f1a007b0a93fee
15 URL:            https://github.com/os/slacker/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 %if %{with python2}
19 BuildRequires:  python-modules
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules
24 BuildRequires:  python3-setuptools
25 %endif
26 Requires:       python-modules
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Slacker is a full-featured Python interface for the Slack API.
32
33 %package -n python3-%{module}
34 Summary:        Slack API client
35 Group:          Libraries/Python
36 Requires:       python3-modules
37
38 %description -n python3-%{module}
39 Slacker is a full-featured Python interface for the Slack API.
40
41 %prep
42 %setup -q -n %{module}-%{version}
43
44 %build
45 %if %{with python2}
46 %py_build
47 %endif
48
49 %if %{with python3}
50 %py3_build
51 %endif
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 %if %{with python2}
56 %py_install
57 %py_postclean
58 %endif
59
60 %if %{with python3}
61 %py3_install
62 %endif
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %if %{with python2}
68 %files
69 %defattr(644,root,root,755)
70 %{py_sitescriptdir}/%{module}
71 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
72 %endif
73
74 %if %{with python3}
75 %files -n python3-%{module}
76 %defattr(644,root,root,755)
77 %{py3_sitescriptdir}/%{module}
78 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
79 %endif
This page took 0.067134 seconds and 2 git commands to generate.