]> git.pld-linux.org Git - packages/python-singledispatch.git/blob - python-singledispatch.spec
- release 2 (by relup.sh)
[packages/python-singledispatch.git] / python-singledispatch.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_with     python3 # CPython 3.x module [functionality already in 3.4+]
5
6 Summary:        Backport of functools.singledispatch from Python 3.4 to Python 2.6-3.3
7 Summary(pl.UTF-8):      Backport functools.singledispatch z Pythona 3.4 do Pythona 2.6-3.3
8 Name:           python-singledispatch
9 Version:        3.4.0.3
10 Release:        2
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.python.org/simple/singledispatch
14 Source0:        https://pypi.python.org/packages/source/s/singledispatch/singledispatch-%{version}.tar.gz
15 # Source0-md5:  af2fc6a3d6cc5a02d0bf54d909785fcb
16 URL:            https://pypi.python.org/pypi/singledispatch
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.6
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.2
25 BuildRequires:  python3-modules < 1:3.4
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.6
29 Requires:       python-six
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 PEP 443 (<http://www.python.org/dev/peps/pep-0443/>) proposed to
35 expose a mechanism in the functools standard library module in Python 3.4
36 that provides a simple form of generic programming known as
37 single-dispatch generic functions.
38
39 This library is a backport of this functionality to Python 2.6 - 3.3.
40
41 %description -l pl.UTF-8
42 PEP 443 (<http://www.python.org/dev/peps/pep-0443/>) zaproponował
43 udostępnienie mechanizmu w module biblioteki standardowej functools w
44 Pythonie 3.4 udostępniającą prostą postać programowania generycznego,
45 znaną jako funkcje generyczne single-dispatch.
46
47 Ten moduł to backport tej funkcji do Pythona w wersjach 2.6 - 3.3.
48
49 %package -n python3-singledispatch
50 Summary:        Backport of functools.singledispatch from Python 3.4 to Python 2.6-3.3
51 Summary(pl.UTF-8):      Backport functools.singledispatch z Pythona 3.4 do Pythona 2.6-3.3
52 Group:          Libraries/Python
53 Requires:       python3-modules >= 1:3.2
54 Requires:       python3-modules < 1:3.4
55 Requires:       python3-six
56
57 %description -n python3-singledispatch
58 PEP 443 (<http://www.python.org/dev/peps/pep-0443/>) proposed to
59 expose a mechanism in the functools standard library module in Python 3.4
60 that provides a simple form of generic programming known as
61 single-dispatch generic functions.
62
63 This library is a backport of this functionality to Python 2.6 - 3.3.
64
65 %description -n python3-singledispatch -l pl.UTF-8
66 PEP 443 (<http://www.python.org/dev/peps/pep-0443/>) zaproponował
67 udostępnienie mechanizmu w module biblioteki standardowej functools w
68 Pythonie 3.4 udostępniającą prostą postać programowania generycznego,
69 znaną jako funkcje generyczne single-dispatch.
70
71 Ten moduł to backport tej funkcji do Pythona w wersjach 2.6 - 3.3.
72
73 %prep
74 %setup -q -n singledispatch-%{version}
75
76 %build
77 %if %{with python2}
78 %py_build
79 %endif
80
81 %if %{with python3}
82 %py3_build
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %py_install
90
91 %py_postclean
92 %endif
93
94 %if %{with python3}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc README.rst
105 %{py_sitescriptdir}/singledispatch.py[co]
106 %{py_sitescriptdir}/singledispatch_helpers.py[co]
107 %{py_sitescriptdir}/singledispatch-%{version}-py*.egg-info
108 %endif
109
110 %if %{with python3}
111 %files -n python3-singledispatch
112 %defattr(644,root,root,755)
113 %doc README.rst
114 %{py3_sitescriptdir}/singledispatch.py
115 %{py3_sitescriptdir}/singledispatch_helpers.py
116 %{py3_sitescriptdir}/__pycache__/singledispatch.cpython-*.py[co]
117 %{py3_sitescriptdir}/__pycache__/singledispatch_helpers.cpython-*.py[co]
118 %{py3_sitescriptdir}/singledispatch-%{version}-py*.egg-info
119 %endif
This page took 0.103744 seconds and 3 git commands to generate.