]> git.pld-linux.org Git - packages/python-simplejson.git/blob - python-simplejson.spec
b0b554d12f37baa692465a29bcf94fdbf4ecbe04
[packages/python-simplejson.git] / python-simplejson.spec
1 # TODO: optflags
2 %define         module          simplejson
3 Summary:        Simple, fast, extensible JSON encoder/decoder for Python
4 Summary(pl.UTF-8):      Prosty, szybki, rozszerzalny (de)koder JSON dla Pythona
5 Name:           python-%{module}
6 Version:        2.5.2
7 Release:        1
8 License:        MIT
9 Group:          Libraries
10 Source0:        http://pypi.python.org/packages/source/s/%{module}/%{module}-%{version}.tar.gz
11 # Source0-md5:  d7a7acf0bd7681bd116b5c981d2f7959
12 URL:            http://undefined.org/python/#simplejson
13 BuildRequires:  python >= 1:2.4
14 BuildRequires:  python-devel
15 BuildRequires:  python-setuptools >= 0.6-0.c1
16 BuildRequires:  rpm-pythonprov
17 %pyrequires_eq  python-libs
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 simplejson is a simple, fast, complete, correct and extensible JSON
22 <http://json.org/> encoder and decoder for Python 2.4+.
23
24 %description -l pl.UTF-8
25 simplejson to prosty, szybki, pełny, poprawny i rozszerzalny koder i
26 dekoder JSON (<http://json.org/>) dla Pythona 2.4 i nowszych wersji.
27
28 %prep
29 %setup -qn %{module}-%{version}
30
31 %build
32 %{__python} setup.py build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 %{__python} setup.py install \
38         --root=$RPM_BUILD_ROOT \
39         --optimize=2
40
41 %py_postclean
42 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/simplejson/tests
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %dir %{py_sitedir}/simplejson
50 %{py_sitedir}/simplejson/*.py[co]
51 %attr(755,root,root) %{py_sitedir}/simplejson/*.so
52 %{py_sitedir}/simplejson-%{version}-py*.egg-info
This page took 0.060209 seconds and 2 git commands to generate.