]> git.pld-linux.org Git - packages/python-simplejson.git/blob - python-simplejson.spec
- converted to UTF-8
[packages/python-simplejson.git] / python-simplejson.spec
1 # $Revision: 1.13 $
2 %define         module          simplejson
3 Summary:        Simple, fast, extensible JSON encoder/decoder for Python
4 Summary(pl.UTF-8):   Prosty, szybki, rozszerzalny (de)koder JSON dla Pythona
5 Name:           python-%{module}
6 Version:        1.4
7 Release:        0.4
8 License:        MIT
9 Group:          Libraries
10 Source0:        http://cheeseshop.python.org/packages/source/s/simplejson/%{module}-%{version}.tar.gz
11 # Source0-md5:  5fbad786a4b151d44a9b1e1e157e5510
12 URL:            http://undefined.org/python/#simplejson
13 BuildRequires:  python >= 1:2.5
14 BuildRequires:  python-setuptools >= 0.6-0.c1
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-libs
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 simplejson is a simple, fast, complete, correct and extensible JSON
22 <http://json.org/> encoder and decoder for Python 2.3+. It is pure
23 Python code with no dependencies.
24
25 %description -l pl.UTF-8
26 simplejson to prosty, szybki, pełny, poprawny i rozszerzalny koder i
27 dekoder JSON (<http://json.org/>) dla Pythona 2.3 i nowszych wersji.
28 Jest to kod wyłącznie w Pythonie bez dodatkowych zależności.
29
30 %prep
31 %setup -qn %{module}-%{version}
32
33 %build
34 python setup.py build
35         
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 python setup.py install \
40         --root=$RPM_BUILD_ROOT \
41         --optimize=2
42
43 %py_postclean
44 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/simplejson/tests
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %dir %{py_sitescriptdir}/simplejson
52 %{py_sitescriptdir}/simplejson/*.py[co]
53 %{py_sitescriptdir}/simplejson-%{version}-py*.egg-info
This page took 0.103033 seconds and 3 git commands to generate.