]> git.pld-linux.org Git - packages/python-setuptools_scm.git/blob - python-setuptools_scm.spec
cb12e7000ae10f0782480fa303664b91fe651d84
[packages/python-setuptools_scm.git] / python-setuptools_scm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # py.test tests
4 %bcond_with     tests_scm       # py.test tests using SCM programs (git, hg)
5 %bcond_without  python2         # CPython 2.x module
6 %bcond_without  python3         # CPython 3.x module
7
8 Summary:        Python 2 package to manager versions by scm tags
9 Summary(pl.UTF-8):      Pakiet Pythona 2 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
10 Name:           python-setuptools_scm
11 Version:        3.3.1
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/setuptools_scm/
16 Source0:        https://files.pythonhosted.org/packages/source/s/setuptools_scm/setuptools_scm-%{version}.tar.gz
17 # Source0-md5:  2b1a20b6a7e264dfac7bc297509c10c6
18 URL:            https://github.com/pypa/setuptools_scm
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-py >= 1.4.26
24 BuildRequires:  python-pytest >= 3.1.0
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-setuptools
29 BuildRequires:  python3-modules >= 1:3.4
30 %if %{with tests}
31 BuildRequires:  python3-py >= 1.4.26
32 BuildRequires:  python3-pytest >= 3.1.0
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 %if %{with tests_scm}
38 BuildRequires:  git-core
39 BuildRequires:  mercurial
40 %endif
41 Requires:       python-setuptools
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 setuptools_scm is a simple utility for the setup_requires feature of
47 setuptools for use in Mercurial and Git based projects.
48
49 %description -l pl.UTF-8
50 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
51 setuptools przeznaczone do stosowania w projektach opatych na
52 systemach kontroli wersji Mercurial i Git.
53
54 %package -n python3-setuptools_scm
55 Summary:        Python 3 package to manager versions by scm tags
56 Summary(pl.UTF-8):      Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
57 Group:          Libraries/Python
58 Requires:       python3-setuptools
59
60 %description -n python3-setuptools_scm
61 setuptools_scm is a simple utility for the setup_requires feature of
62 setuptools for use in Mercurial and Git based projects.
63
64 %description -n python3-setuptools_scm -l pl.UTF-8
65 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
66 setuptools przeznaczone do stosowania w projektach opatych na
67 systemach kontroli wersji Mercurial i Git.
68
69 %prep
70 %setup -q -n setuptools_scm-%{version}
71
72 %if %{without tests_scm}
73 %{__rm} testing/test_{file_finder,git,mercurial,regressions}.py
74 %endif
75
76 # tries to install using pip
77 %{__rm} testing/test_setuptools_support.py
78
79 %build
80 %if %{with python2}
81 %py_build
82
83 %if %{with tests}
84 PYTHONPATH=$(pwd)/build-2/lib \
85 %{__python} -m pytest
86 %endif
87 %endif
88
89 %if %{with python3}
90 %py3_build
91
92 %if %{with tests}
93 PYTHONPATH=$(pwd)/build-3/lib \
94 %{__python3} -m pytest
95 %endif
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %py_install
103
104 %py_postclean
105 %endif
106
107 %if %{with python3}
108 %py3_install
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %if %{with python2}
115 %files
116 %defattr(644,root,root,755)
117 %doc CHANGELOG.rst LICENSE README.rst
118 %{py_sitescriptdir}/setuptools_scm
119 %{py_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
120 %endif
121
122 %if %{with python3}
123 %files -n python3-setuptools_scm
124 %defattr(644,root,root,755)
125 %doc CHANGELOG.rst LICENSE README.rst
126 %{py3_sitescriptdir}/setuptools_scm
127 %{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
128 %endif
This page took 0.053273 seconds and 2 git commands to generate.