]> git.pld-linux.org Git - packages/python-setuptools_scm.git/blob - python-setuptools_scm.spec
a04aa6f2deb13e9b125a4e26c691019ecfada631
[packages/python-setuptools_scm.git] / python-setuptools_scm.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # py.test tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Python 2 package to manager versions by scm tags
8 Summary(pl.UTF-8):      Pakiet Pythona 2 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
9 Name:           python-setuptools_scm
10 Version:        1.15.0
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/setuptools_scm
15 Source0:        https://pypi.python.org/packages/80/b7/31b6ae5fcb188e37f7e31abe75f9be90490a5456a72860fa6e643f8a3cbc/setuptools_scm-%{version}.tar.gz
16 # Source0-md5:  b6916c78ed6253d6602444fad4279c5b
17 URL:            https://github.com/pypa/setuptools_scm
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.6
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-py >= 1.4.26
23 BuildRequires:  python-pytest
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-setuptools
28 BuildRequires:  python3-modules >= 1:3.3
29 %if %{with tests}
30 BuildRequires:  python3-py >= 1.4.26
31 BuildRequires:  python3-pytest
32 %endif
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 Requires:       python-setuptools
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 setuptools_scm is a simple utility for the setup_requires feature of
42 setuptools for use in Mercurial and Git based projects.
43
44 %description -l pl.UTF-8
45 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
46 setuptools przeznaczone do stosowania w projektach opatych na
47 systemach kontroli wersji Mercurial i Git.
48
49 %package -n python3-setuptools_scm
50 Summary:        Python 3 package to manager versions by scm tags
51 Summary(pl.UTF-8):      Pakiet Pythona 3 do zarządzania wersjami poprzez etykiety systemu kontroli wersji
52 Group:          Libraries/Python
53 Requires:       python3-setuptools
54
55 %description -n python3-setuptools_scm
56 setuptools_scm is a simple utility for the setup_requires feature of
57 setuptools for use in Mercurial and Git based projects.
58
59 %description -n python3-setuptools_scm -l pl.UTF-8
60 setuptools_scm to proste narzędzie dla funkcji setup_requires modułu
61 setuptools przeznaczone do stosowania w projektach opatych na
62 systemach kontroli wersji Mercurial i Git.
63
64 %prep
65 %setup -q -n setuptools_scm-%{version}
66
67 %build
68 %if %{with python2}
69 %py_build
70
71 %{?with_tests:%{__python} -mpytest}
72 %endif
73
74 %if %{with python3}
75 %py3_build
76
77 %{?with_tests:%{__python3} -mpytest}
78 %endif
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %if %{with python2}
84 %py_install
85
86 %py_postclean
87 %endif
88
89 %if %{with python3}
90 %py3_install
91 %endif
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %if %{with python2}
97 %files
98 %defattr(644,root,root,755)
99 %doc CHANGELOG.rst LICENSE README.rst
100 %{py_sitescriptdir}/setuptools_scm
101 %{py_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
102 %endif
103
104 %if %{with python3}
105 %files -n python3-setuptools_scm
106 %defattr(644,root,root,755)
107 %doc CHANGELOG.rst LICENSE README.rst
108 %{py3_sitescriptdir}/setuptools_scm
109 %{py3_sitescriptdir}/setuptools_scm-%{version}-py*.egg-info
110 %endif
This page took 0.067372 seconds and 2 git commands to generate.