]> git.pld-linux.org Git - packages/python-setuptools_git_ls_files.git/blob - python-setuptools_git_ls_files.spec
52a95a577b433ebe9f62e8f0196c59ed9468d563
[packages/python-setuptools_git_ls_files.git] / python-setuptools_git_ls_files.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Use git to list all files, including submodules
7 Summary(pl.UTF-8):      Użycie gita do listy wszystkich plików, wraz z podmodułami
8 Name:           python-setuptools_git_ls_files
9 Version:        0.1.2
10 Release:        1
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/setuptools-git-ls-files/
14 Source0:        https://files.pythonhosted.org/packages/source/s/setuptools-git-ls-files/setuptools_git_ls_files-%{version}.tar.gz
15 # Source0-md5:  4a904dc4b154bff7de3cb41fca67b234
16 URL:            https://pypi.org/project/setuptools-git-ls-files/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.5
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.7
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A plugin for setuptools that finds all git tracked files, including
33 submodules.
34
35 %description -l pl.UTF-8
36 Wtyczka setuptools znajdująca wszystkie pliki śledzone przez gita,
37 wraz z podmodułami.
38
39 %package -n python3-setuptools_git_ls_files
40 Summary:        Use git to list all files, including submodules
41 Summary(pl.UTF-8):      Użycie gita do listy wszystkich plików, wraz z podmodułami
42 Group:          Libraries/Python
43 Requires:       python3-modules >= 1:3.5
44
45 %description -n python3-setuptools_git_ls_files
46 A plugin for setuptools that finds all git tracked files, including
47 submodules.
48
49 %description -n python3-setuptools_git_ls_files -l pl.UTF-8
50 Wtyczka setuptools znajdująca wszystkie pliki śledzone przez gita,
51 wraz z podmodułami.
52
53 %prep
54 %setup -q -n setuptools_git_ls_files-%{version}
55
56 %build
57 %if %{with python2}
58 %py_build
59 %endif
60
61 %if %{with python3}
62 %py3_build
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %if %{with python2}
69 %py_install
70
71 %py_postclean
72 %endif
73
74 %if %{with python3}
75 %py3_install
76 %endif
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %files
83 %defattr(644,root,root,755)
84 %doc LICENSE README.md
85 %{py_sitescriptdir}/setuptools_git_ls_files.py[co]
86 %{py_sitescriptdir}/setuptools_git_ls_files-%{version}-py*.egg-info
87 %endif
88
89 %if %{with python3}
90 %files -n python3-setuptools_git_ls_files
91 %defattr(644,root,root,755)
92 %doc LICENSE README.md
93 %{py3_sitescriptdir}/setuptools_git_ls_files.py
94 %{py3_sitescriptdir}/__pycache__/setuptools_git_ls_files.cpython-*.py[co]
95 %{py3_sitescriptdir}/setuptools_git_ls_files-%{version}-py*.egg-info
96 %endif
This page took 0.051944 seconds and 2 git commands to generate.