]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
Version 6.0.2-1. pytho3 package added.
[packages/python-setuptools.git] / python-setuptools.spec
1 #
2 # Conditional build:
3 %bcond_with     doc             # don't build doc
4 %bcond_with     tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module  setuptools
9 Summary:        A collection of enhancements to the Python distutils
10 Summary(pl.UTF-8):      Zestaw rozszerzeń dla pythonowych distutils
11 Name:           python-setuptools
12 Version:        6.0.2
13 Release:        1
14 Epoch:          1
15 License:        PSF or ZPL
16 Group:          Development/Languages/Python
17 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
18 # Source0-md5:  b79fab610e362fe8e3a9cb92fb9d95ef
19 URL:            https://bitbucket.org/pypa/setuptools
20 %if %{with python2}
21 BuildRequires:  python-distribute
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-distribute
25 BuildRequires:  python3-modules
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 setuptools is a collection of enhancements to the Python distutils
32 that allow you to more easily build and distribute Python packages,
33 especially ones that have dependencies on other packages.
34
35 This package contains the runtime components of setuptools, necessary
36 to execute the software that requires pkg_resources.py.
37
38 %description -l pl.UTF-8
39 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
40 łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
41 tych mających zależności od innych pakietów.
42
43 Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
44 uruchamiania kodu wymagającego pkg_resources.py.
45
46 %package -n python3-%{module}
47 Summary:        -
48 Summary(pl.UTF-8):      -
49 Group:          Libraries/Python
50 Requires:       python3-modules
51
52 %description -n python3-%{module}
53
54 %description -n python3-%{module} -l pl.UTF-8
55
56 %package apidocs
57 Summary:        %{module} API documentation
58 Summary(pl.UTF-8):      Dokumentacja API %{module}
59 Group:          Documentation
60
61 %description apidocs
62 API documentation for %{module}.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API %{module}.
66
67 %package devel
68 Summary:        Download, install, upgrade, and uninstall Python packages
69 Summary(pl.UTF-8):      Ściąganie, instalacja, uaktualnianie i usuwanie pakietów Pythona
70 Group:          Development/Languages
71 Requires:       %{name} = %{epoch}:%{version}-%{release}
72 Requires:       python-devel
73
74 %description devel
75 setuptools is a collection of enhancements to the Python distutils
76 that allow you to more easily build and distribute Python packages,
77 especially ones that have dependencies on other packages.
78
79 This package contains the components necessary to build and install
80 software requiring setuptools.
81
82 %description devel -l pl.UTF-8
83 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
84 łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
85 tych mających zależności od innych pakietów.
86
87 Ten pakiet zawiera składniki potrzebne do budowania i instalacji
88 oprogramowania wymagającego setuptools.
89
90 %prep
91 %setup -q -n %{module}-%{version}
92
93 %build
94 %if %{with python2}
95 %{__python} setup.py build --build-base build-2 %{?with_tests:test}
96 %endif
97
98 %if %{with python3}
99 %{__python3} setup.py build --build-base build-3 %{?with_tests:test}
100 %endif
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %if %{with python2}
106 %{__python} setup.py \
107         build --build-base build-2 \
108         install --skip-build \
109         --optimize=2 \
110         --root=$RPM_BUILD_ROOT
111 %endif
112
113 %if %{with python3}
114 %{__python3} setup.py \
115         build --build-base build-3 \
116         install --skip-build \
117         --optimize=2 \
118         --root=$RPM_BUILD_ROOT
119 %endif
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %if %{with python2}
125 %files
126 %defattr(644,root,root,755)
127 %doc CHANGES.txt README.txt DEVGUIDE.txt 
128 %attr(755,root,root) %{_bindir}/easy_install
129 %attr(755,root,root) %{_bindir}/easy_install-2.*
130 %{py_sitescriptdir}/%{module}
131 %{py_sitescriptdir}/_markerlib
132 %{py_sitescriptdir}/easy_install.py[co]
133 %{py_sitescriptdir}/pkg_resources.py[co]
134
135 %if "%{py_ver}" > "2.4"
136 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
137 %endif
138 %endif
139
140 %if %{with python3}
141 %files -n python3-%{module}
142 %defattr(644,root,root,755)
143 %doc CHANGES.txt README.txt DEVGUIDE.txt 
144 %attr(755,root,root) %{_bindir}/easy_install-3.*
145 %{py3_sitescriptdir}/__pycache__/*
146 %{py3_sitescriptdir}/%{module}
147 %{py3_sitescriptdir}/_markerlib
148 %{py3_sitescriptdir}/easy_install.py
149 %{py3_sitescriptdir}/pkg_resources.py
150 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
151 %endif
152
153 %if %{with doc}
154 %files apidocs
155 %defattr(644,root,root,755)
156 # %doc docs/_build/html/*
157 %endif
158
159
This page took 0.216328 seconds and 3 git commands to generate.