]> git.pld-linux.org Git - packages/python-setuptools.git/blob - python-setuptools.spec
321c3ffc34f46908fcf0ced456ff893fa7d4b6ad
[packages/python-setuptools.git] / python-setuptools.spec
1 %define         module  setuptools
2 %define         subver  c11
3 %define         rel     3
4 Summary:        A collection of enhancements to the Python distutils
5 Summary(pl.UTF-8):      Zestaw rozszerzeń dla pythonowych distutils
6 Name:           python-setuptools
7 Version:        0.6
8 Release:        2.%{subver}.%{rel}
9 Epoch:          1
10 License:        GPL
11 Group:          Development/Languages/Python
12 Source0:        http://cheeseshop.python.org/packages/source/s/setuptools/setuptools-%{version}%{subver}.tar.gz
13 # Source0-md5:  7df2a529a074f613b509fb44feefe74e
14 URL:            http://peak.telecommunity.com/DevCenter/setuptools
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 setuptools is a collection of enhancements to the Python distutils
23 that allow you to more easily build and distribute Python packages,
24 especially ones that have dependencies on other packages.
25
26 This package contains the runtime components of setuptools, necessary
27 to execute the software that requires pkg_resources.py.
28
29 %description -l pl.UTF-8
30 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
31 łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
32 tych mających zależności od innych pakietów.
33
34 Ten pakiet zawiera składniki uruchomieniowe setuptools, potrzebne do
35 uruchamiania kodu wymagającego pkg_resources.py.
36
37 %package devel
38 Summary:        Download, install, upgrade, and uninstall Python packages
39 Summary(pl.UTF-8):      Ściąganie, instalacja, uaktualnianie i usuwanie pakietów Pythona
40 Group:          Development/Languages
41 Requires:       %{name} = %{epoch}:%{version}-%{release}
42 Requires:       python-devel
43
44 %description devel
45 setuptools is a collection of enhancements to the Python distutils
46 that allow you to more easily build and distribute Python packages,
47 especially ones that have dependencies on other packages.
48
49 This package contains the components necessary to build and install
50 software requiring setuptools.
51
52 %description devel -l pl.UTF-8
53 setuptools to zestaw rozszerzeń do pythonowych distutils umożliwiający
54 łatwiejsze budowanie i rozprowadzanie pakietów Pythona, szczególnie
55 tych mających zależności od innych pakietów.
56
57 Ten pakiet zawiera składniki potrzebne do budowania i instalacji
58 oprogramowania wymagającego setuptools.
59
60 %prep
61 %setup -q -n %{module}-%{version}%{subver}
62
63 %build
64 %{__python} ./setup.py build
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__python} ./setup.py install \
70         --single-version-externally-managed \
71         --optimize 2 \
72         --root=$RPM_BUILD_ROOT
73
74 rm -f $RPM_BUILD_ROOT%{py_sitescriptdir}/*/*.exe
75
76 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
77 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
78 %py_postclean
79 install site.py $RPM_BUILD_ROOT%{py_sitescriptdir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc pkg_resources.txt setuptools.txt
87 %{py_sitescriptdir}/%{module}*
88 %{py_sitescriptdir}/pkg_resources.py[co]
89 %{py_sitescriptdir}/site.py[co]
90 %{py_sitescriptdir}/site.py
91
92 %files devel
93 %defattr(644,root,root,755)
94 %doc EasyInstall.txt README.txt api_tests.txt
95 %attr(755,root,root) %{_bindir}/easy_install*
96 %{py_sitescriptdir}/easy_install.py[co]
This page took 0.058426 seconds and 2 git commands to generate.