]> git.pld-linux.org Git - packages/python3-setproctitle.git/blob - python-setproctitle.spec
b5947a471381be9a3b4c9df396ce9164aaac674d
[packages/python3-setproctitle.git] / python-setproctitle.spec
1 Summary:        Python module to customize a process title
2 Name:           python-setproctitle
3 Version:        1.1.10
4 Release:        8
5 License:        BSD
6 Group:          Development/Languages/Python
7 URL:            http://pypi.python.org/pypi/setproctitle
8 BuildRequires:  rpmbuild(macros) >= 1.710
9 Source0:        https://pypi.python.org/packages/5a/0d/dc0d2234aacba6cf1a729964383e3452c52096dc695581248b548786f2b3/setproctitle-%{version}.tar.gz
10 # Source0-md5:  2dcdd1b761700a5a13252fea3dfd1977
11 BuildRequires:  python-devel
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Python module allowing a process to change its title as displayed by
16 system tool such as ps and top.
17
18 It's useful in multiprocess systems, allowing to identify tasks each
19 forked process is busy with. This technique has been used by
20 PostgreSQL and OpenSSH.
21
22 It's based on PostgreSQL implementation which has proven to be
23 portable.
24
25 %package -n python3-setproctitle
26 Summary:        Python module to customize a process title
27 BuildRequires:  python3-devel
28
29 %description -n python3-setproctitle
30 Python module allowing a process to change its title as displayed by
31 system tool such as ps and top.
32
33 It's useful in multi-process systems, allowing to identify tasks each
34 forked process is busy with. This technique has been used by
35 PostgreSQL and OpenSSH.
36
37 It's based on PostgreSQL implementation which has proven to be
38 portable.
39
40 %prep
41 %setup -q -n setproctitle-%{version}
42
43 %build
44 %{__python} setup.py \
45         build -b build-2
46 %{__python3} setup.py \
47         build -b build-3
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %py_install \
53         --root $RPM_BUILD_ROOT
54
55 chmod 0755 $RPM_BUILD_ROOT%{py_sitedir}/setproctitle.so
56
57 %py3_install \
58         --root $RPM_BUILD_ROOT
59
60 chmod 0755 $RPM_BUILD_ROOT%{py3_sitedir}/setproctitle*.so
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README.rst
68 %attr(755,root,root) %{py_sitedir}/setproctitle.so
69 %{py_sitedir}/setproctitle-*.egg-info
70
71 %files -n python3-setproctitle
72 %defattr(644,root,root,755)
73 %doc README.rst
74 %attr(755,root,root) %{py3_sitedir}/setproctitle.*.so
75 %{py3_sitedir}/setproctitle-*.egg-info
This page took 0.068113 seconds and 2 git commands to generate.