]> git.pld-linux.org Git - packages/python-serial.git/blob - python-serial.spec
- removed %%include /usr/lib/rpm/macros.python
[packages/python-serial.git] / python-serial.spec
1 #TODO:
2 # - add descriptions, all kind of cosmetics, subpackage examples, docs
3
4
5 %define module  serial
6
7 Summary:        Serial port interface module
8 Summary(pl):    Modu³ interfejsu do portu szeregowego
9 Name:           python-serial
10 Version:        2.0
11 Release:        0.1
12 License:        GPL
13 Group:          Development/Languages/Python
14 Source0:        http://dl.sourceforge.net/pyserial/pyserial-%{version}.zip
15 # Source0-md5:  80a26774156ba38b63b0945f2b511695
16 URL:            http://pyserial.sf.net
17 %pyrequires_eq  python
18 BuildRequires:  python-devel
19 BuildRequires:  rpm-pythonprov >= 4.0.2-50
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module encapsulates the access for the serial port. It provides
25 backends for Python running on Windows, Linux, BSD (possibly any POSIX
26 compilant system) and Jython. The module named "serial" automatically
27 selects the appropriate backend.
28
29 %description -l pl
30 Ten modu³ opakowuje dostêp do portu szeregowego. Dostarcza backendy
31 dla Pythona dzia³aj±cego na Windows, Linuksie, BSD (byæ mo¿e dowolnym
32 systemie zgodnym z POSIX) oraz Jythona. Modu³ o nazwie "serial"
33 automatycznie wybiera w³a¶ciwy backend.
34
35 %prep
36 %setup  -q -n pyserial-%{version}
37
38 %build
39 python ./setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 python ./setup.py install \
45         --optimize 2 \
46         --root=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %dir %{py_sitedir}/%{module}
54 %{py_sitedir}/%{module}/__init__.pyc
55 %{py_sitedir}/%{module}/__init__.pyo
56 %{py_sitedir}/%{module}/serialposix.pyc
57 %{py_sitedir}/%{module}/serialposix.pyo
58 %{py_sitedir}/%{module}/serialutil.pyc
59 %{py_sitedir}/%{module}/serialutil.pyo
This page took 0.063661 seconds and 4 git commands to generate.