]> git.pld-linux.org Git - packages/python-serial.git/blob - python-serial.spec
- move to HEAD (from RA-branch)
[packages/python-serial.git] / python-serial.spec
1 #TODO:
2 # - add descriptions, all kind of cosmetics, subpackage examples, docs
3
4 %include        /usr/lib/rpm/macros.python
5
6 %define module serial
7
8 Summary:        Serial interface module
9 Summary(pl):    TODO
10 Name:           python-serial
11 Version:        2.0
12 Release:        0.1
13 License:        GPL
14 Group:          Python
15 ######          Unknown group!
16 Source0:        http://dl.sourceforge.net/pyserial/pyserial-%{version}.zip
17 # Source0-md5:  80a26774156ba38b63b0945f2b511695
18 URL:            http://pyserial.sf.net
19 %pyrequires_eq  python
20 BuildRequires:  rpm-pythonprov >= 4.0.2-50
21 BuildRequires:  python-devel
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module encapsulates the access for the serial port. It provides
27 backends for Python running on Windows, Linux, BSD (possibly any POSIX
28 compilant system) and Jython. The module named "serial" automatically
29 selects the appropriate backend.
30
31 %description -l pl
32 TODO
33
34
35 %prep
36 %setup  -q -n pyserial-%{version}
37
38 %build
39 python ./setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 python ./setup.py install --optimize 2 --root=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %dir %{py_sitedir}/%{module}
52 %{py_sitedir}/%{module}/__init__.pyc
53 %{py_sitedir}/%{module}/__init__.pyo
54 %{py_sitedir}/%{module}/serialposix.pyc
55 %{py_sitedir}/%{module}/serialposix.pyo
56 %{py_sitedir}/%{module}/serialutil.pyc
57 %{py_sitedir}/%{module}/serialutil.pyo
This page took 0.032007 seconds and 4 git commands to generate.