]> git.pld-linux.org Git - packages/python-serial.git/blob - python-serial.spec
- release 2
[packages/python-serial.git] / python-serial.spec
1
2 %define module  serial
3
4 Summary:        Serial port interface module
5 Summary(pl.UTF-8):      Moduł interfejsu do portu szeregowego
6 Name:           python-serial
7 Version:        2.4
8 Release:        2
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/pyserial/pyserial-%{version}.tar.gz
12 # Source0-md5:  eec19df59fd75ba5a136992897f8e468
13 URL:            http://pyserial.wiki.sourceforge.net/pySerial
14 %pyrequires_eq  python
15 BuildRequires:  python-devel
16 BuildRequires:  unzip
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This module encapsulates the access for the serial port. It provides
22 backends for Python running on Windows, Linux, BSD (possibly any POSIX
23 compilant system) and Jython. The module named "serial" automatically
24 selects the appropriate backend.
25
26 %description -l pl.UTF-8
27 Ten moduł opakowuje dostęp do portu szeregowego. Dostarcza backendy
28 dla Pythona działającego na Windows, Linuksie, BSD (być może dowolnym
29 systemie zgodnym z POSIX) oraz Jythona. Moduł o nazwie "serial"
30 automatycznie wybiera właściwy backend.
31
32 %prep
33 %setup  -q -n pyserial-%{version}
34
35 %build
36 python ./setup.py build
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
41
42 python ./setup.py install \
43         --optimize 2 \
44         --root=$RPM_BUILD_ROOT
45
46 mv examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*serialjava*" -exec rm {} \;
49 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*serialwin*" -exec rm {} \;
50 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc CHANGES.txt LICENSE.txt README.txt
58 %{_examplesdir}/%{name}-%{version}
59 %dir %{py_sitescriptdir}/%{module}
60 %{py_sitescriptdir}/%{module}/*.py[co]
61 %{py_sitescriptdir}/*egg-info
This page took 0.035629 seconds and 4 git commands to generate.