]> git.pld-linux.org Git - packages/python-seqdiag.git/blob - python-seqdiag.spec
- release 3 (by relup.sh)
[packages/python-seqdiag.git] / python-seqdiag.spec
1 %define         module  seqdiag
2 Summary:        seqkdiag generate sequence-diagram image file from spec-text file
3 Name:           python-%{module}
4 Version:        0.7.2
5 Release:        3
6 License:        Apache v2.0
7 Group:          Development/Languages
8 URL:            http://blockdiag.com/en/seqdiag/index.html
9 Source0:        http://pypi.python.org/packages/source/s/%{module}/%{module}-%{version}.tar.gz
10 # Source0-md5:  428341e76c3434ba3a87a063ca5fb721
11 BuildRequires:  rpmbuild(macros) >= 1.710
12 BuildRequires:  sed >= 4.0
13 Requires:       python-blockdiag >= 1.1.0
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 seqdiag generates sequence-diagram image file from spec-text files.
19
20 Features:
21 - Generate sequence-diagram from dot like text (basic feature).
22 - Multilingualization for node-label (utf-8 only).
23
24 %prep
25 %setup -q -n %{module}-%{version}
26 %{__sed} -i -e 's/^from ez_setup/#from ez_setup/' setup.py
27 %{__sed} -i -e 's/^use_setuptools()/#use_setuptools()/' setup.py
28
29 %build
30 %py_build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 %py_install \
35         --root $RPM_BUILD_ROOT
36
37 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
38 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}_sphinxhelper.py[co]
39
40 install -d $RPM_BUILD_ROOT%{_mandir}/man1
41 cp -p %{module}.1 $RPM_BUILD_ROOT%{_mandir}/man1
42
43 %py_postclean
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %attr(755,root,root) %{_bindir}/seqdiag
51 %{_mandir}/man1/*.1*
52 %dir %{py_sitescriptdir}/%{module}
53 %{py_sitescriptdir}/%{module}/*.py[co]
54 %dir %{py_sitescriptdir}/%{module}/utils
55 %{py_sitescriptdir}/%{module}/utils/*.py[co]
56 %dir %{py_sitescriptdir}/%{module}/utils/rst
57 %{py_sitescriptdir}/%{module}/utils/rst/*.py[co]
58 %if "%{py_ver}" > "2.4"
59 %{py_sitescriptdir}/%{module}-%{version}-*.egg-info
60 %endif
This page took 0.045512 seconds and 3 git commands to generate.