]> git.pld-linux.org Git - packages/python-semantic_version.git/blob - python-semantic_version.spec
53294d4edffe169cf5575483d94128bb62a10c1a
[packages/python-semantic_version.git] / python-semantic_version.spec
1 %bcond_without  python2 # CPython 2.x module
2 %bcond_without  python3 # CPython 3.x module
3
4 %define         module          semantic_version
5 Summary:        A library implementing the 'SemVer' scheme
6 Name:           python-%{module}
7 Version:        2.8.5
8 Release:        1
9 License:        BSD
10 Group:          Libraries/Python
11 #Source0Download: https://pypi.org/simple/semantic-version/
12 Source0:        https://files.pythonhosted.org/packages/source/s/semantic-version/%{module}-%{version}.tar.gz
13 # Source0-md5:  76d7364def7ee487b6153d40b13de904
14 URL:            https://pypi.org/project/semantic-version/
15 %if %{with python2}
16 BuildRequires:  python-modules >= 1:2.7
17 BuildRequires:  python-setuptools
18 %endif
19 %if %{with python3}
20 BuildRequires:  python3-modules >= 1:3.4
21 BuildRequires:  python3-setuptools
22 %endif
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 Requires:       python-modules >= 1:2.7
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This small python library provides a few tools to handle SemVer in
31 Python. It follows strictly the 2.0.0 version of the SemVer scheme.
32
33 %package -n python3-%{module}
34 Summary:        A library implementing the 'SemVer' scheme
35 Group:          Libraries/Python
36 Requires:       python3-modules >= 1:3.4
37
38 %description -n python3-%{module}
39 This small python library provides a few tools to handle SemVer in
40 Python. It follows strictly the 2.0.0 version of the SemVer scheme.
41
42 %prep
43 %setup -q -n %{module}-%{version}
44
45 %build
46 %if %{with python2}
47 %py_build
48 %endif
49
50 %if %{with python3}
51 %py3_build
52 %endif
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %if %{with python2}
58 %py_install
59
60 %py_postclean
61 %endif
62
63 %if %{with python3}
64 %py3_install
65 %endif
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %if %{with python2}
71 %files
72 %defattr(644,root,root,755)
73 %doc CREDITS ChangeLog README.rst
74 %{py_sitescriptdir}/%{module}
75 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
76 %endif
77
78 %if %{with python3}
79 %files -n python3-%{module}
80 %defattr(644,root,root,755)
81 %doc CREDITS ChangeLog README.rst
82 %{py3_sitescriptdir}/%{module}
83 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
84 %endif
This page took 0.033534 seconds and 2 git commands to generate.