]> git.pld-linux.org Git - packages/python-scandir.git/blob - python-scandir.spec
- updated to 1.5
[packages/python-scandir.git] / python-scandir.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_with     python3 # CPython 3.x module, build for Python3<3.5
7
8 %define         module          scandir
9 %define         egg_name        scandir
10 Summary:        A better directory iterator and faster os.walk() for Python 2
11 Summary(pl.UTF-8):      Lepszy iterator po katalogach i szybsze os.walk() dla Pythona 2
12 Name:           python-%{module}
13 Version:        1.5
14 Release:        1
15 License:        BSD
16 Group:          Libraries/Python
17 #Source0Download: https://github.com/benhoyt/scandir/releases
18 Source0:        https://github.com/benhoyt/scandir/archive/v%{version}/%{module}-%{version}.tar.gz
19 # Source0-md5:  798407545833aa7011c1ee34b580e902
20 URL:            https://github.com/benhoyt/scandir
21 %if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
22 BuildRequires:  glibc-localedb-all
23 %endif
24 %if %{with python2}
25 BuildRequires:  python-modules >= 1:2.6
26 BuildRequires:  python-setuptools
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules >= 1:3.2
30 BuildRequires:  python3-setuptools
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.6
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 scandir() is a directory iteration function like os.listdir(), except
39 that instead of returning a list of bare filenames, it yields DirEntry
40 objects that include file type and stat information along with the
41 name. Using scandir() increases the speed of os.walk() by 2-20 times
42 (depending on the platform and file system) by avoiding unnecessary
43 calls to os.stat() in most cases. scandir is included in the Python
44 3.5+ standard library.
45
46 %description -l pl.UTF-8
47 scandir() to funkcja iterująca po katalogu podobna do os.listdir(),
48 ale zamiast zwracania listy samych nazw plików, przekazująca przez
49 yield obiekty DirEntry, zawierające poza nazwą typ pliku oraz
50 informacje stat. Użycie scandir() przyspiesza os.walk() 2-20 razy (w
51 zależności od platformy i systemu plików), zapobiegając w większości
52 przypadków niepotrzebnym wywołaniom os.stat(). scandir jest zawarte w
53 bibliotece standardowej Pythona 3.5+.
54
55 %package -n python3-%{module}
56 Summary:        A better directory iterator and faster os.walk() for Python 3 < 3.5
57 Summary(pl.UTF-8):      Lepszy iterator po katalogach i szybsze os.walk() dla Pythona 3 < 3.5
58 Group:          Libraries/Python
59 Requires:       python3-modules >= 1:3.2
60
61 %description -n python3-%{module}
62 scandir() is a directory iteration function like os.listdir(), except
63 that instead of returning a list of bare filenames, it yields DirEntry
64 objects that include file type and stat information along with the
65 name. Using scandir() increases the speed of os.walk() by 2-20 times
66 (depending on the platform and file system) by avoiding unnecessary
67 calls to os.stat() in most cases. scandir is included in the Python
68 3.5+ standard library.
69
70 %description -n python3-%{module} -l pl.UTF-8
71 scandir() to funkcja iterująca po katalogu podobna do os.listdir(),
72 ale zamiast zwracania listy samych nazw plików, przekazująca przez
73 yield obiekty DirEntry, zawierające poza nazwą typ pliku oraz
74 informacje stat. Użycie scandir() przyspiesza os.walk() 2-20 razy (w
75 zależności od platformy i systemu plików), zapobiegając w większości
76 przypadków niepotrzebnym wywołaniom os.stat(). scandir jest zawarte w
77 bibliotece standardowej Pythona 3.5+.
78
79 %prep
80 %setup -q -n %{module}-%{version}
81
82 %build
83 %if %{with python2}
84 %py_build
85
86 %if %{with tests}
87 rm -rf test/testdir
88 # Tests fail if unicode is not supported
89 LC_ALL=C.UTF-8 \
90 %{__python} test/run_tests.py
91 %endif
92
93 %endif
94
95 %if %{with python3}
96 %py3_build
97
98 %if %{with tests}
99 rm -rf test/testdir
100 # Tests fail if unicode is not supported
101 LC_ALL=C.UTF-8 \
102 %{__python3} test/run_tests.py
103 %endif
104
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %if %{with python2}
110 %py_install
111 %py_postclean
112 %endif
113
114 %if %{with python3}
115 %py3_install
116 %endif
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %if %{with python2}
122 %files
123 %defattr(644,root,root,755)
124 %doc LICENSE.txt README.rst
125 %{py_sitedir}/scandir.py[co]
126 %attr(755,root,root) %{py_sitedir}/_scandir.so
127 %{py_sitedir}/%{egg_name}-%{version}-py*.egg-info
128 %endif
129
130 %if %{with python3}
131 %files -n python3-%{module}
132 %defattr(644,root,root,755)
133 %doc LICENSE.txt README.rst
134 %{py3_sitedir}/scandir.py
135 %{py3_sitedir}/__pycache__/scandir.cpython-*.pyc
136 %attr(755,root,root) %{py3_sitedir}/_scandir.cpython-*.so
137 %{py3_sitedir}/%{egg_name}-%{version}-py*.egg-info
138 %endif
This page took 0.076157 seconds and 3 git commands to generate.