]> git.pld-linux.org Git - packages/python-ruamel.yaml.git/blob - python-ruamel.yaml.spec
rebuild with tests and docs
[packages/python-ruamel.yaml.git] / python-ruamel.yaml.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          ruamel.yaml
7 Summary:        YAML 1.2 loader/dumper for Python 2
8 Summary(pl.UTF-8):      Biblioteka do wczytywania/zrzucania YAML-a 1.2 dla Pythona 2
9 Name:           python-%{module}
10 Version:        0.16.10
11 Release:        5
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/ruamel.yaml/
15 Source0:        https://files.pythonhosted.org/packages/source/r/ruamel.yaml/%{module}-%{version}.tar.gz
16 # Source0-md5:  02774e7ed3273b3d8eee6c08326b91c4
17 URL:            https://pypi.org/project/ruamel.yaml/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools >= 1:28.7.0
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.5
26 BuildRequires:  python3-setuptools >= 1:28.7.0
27 %endif
28 Requires:       python-modules >= 1:2.7
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 YAML parser/emitter that supports roundtrip preservation of comments,
34 seq/map flow style and map key order.
35
36 %description -l pl.UTF-8
37 Biblioteka do analizy/tworzenia YAML-a zachowująca komentarze i
38 kolejność kluczy w mapach.
39
40 %package -n python3-%{module}
41 Summary:        YAML 1.2 loader/dumper for Python 3
42 Summary(pl.UTF-8):      Biblioteka do wczytywania/zrzucania YAML-a 1.2 dla Pythona 3
43 Group:          Libraries/Python
44 Requires:       python3-modules >= 1:3.5
45
46 %description -n python3-%{module}
47 YAML parser/emitter that supports roundtrip preservation of comments,
48 seq/map flow style and map key order.
49
50 %description -n python3-%{module} -l pl.UTF-8
51 Biblioteka do analizy/tworzenia YAML-a zachowująca komentarze i
52 kolejność kluczy w mapach.
53
54 %prep
55 %setup -q -n %{module}-%{version}
56
57 %build
58 %if %{with python2}
59 %py_build
60 %endif
61
62 %if %{with python3}
63 %py3_build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %py_install
71
72 %py_postclean
73 %endif
74
75 %if %{with python3}
76 %py3_install
77 %endif
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %if %{with python2}
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGES LICENSE README.rst
86 %{py_sitescriptdir}/ruamel/yaml
87 %{py_sitescriptdir}/ruamel.yaml-%{version}-py*.egg-info
88 %{py_sitescriptdir}/ruamel.yaml-%{version}-py*-nspkg.pth
89 %endif
90
91 %if %{with python3}
92 %files -n python3-%{module}
93 %defattr(644,root,root,755)
94 %doc CHANGES LICENSE README.rst
95 %{py3_sitescriptdir}/ruamel/yaml
96 %{py3_sitescriptdir}/ruamel.yaml-%{version}-py*.egg-info
97 %{py3_sitescriptdir}/ruamel.yaml-%{version}-py*-nspkg.pth
98 %endif
This page took 0.072097 seconds and 3 git commands to generate.