]> git.pld-linux.org Git - packages/python-ruamel.base.git/blob - python-ruamel.base.spec
cc156a448c8fc735503e59d09384c30d7d55d5b8
[packages/python-ruamel.base.git] / python-ruamel.base.spec
1 # Conditional build:
2 %bcond_without  python2 # CPython 2.x module
3 %bcond_without  python3 # CPython 3.x module
4
5 %define         module          ruamel.base
6 Summary:        Common routines for ruamel packages
7 Name:           python-%{module}
8 Version:        1.0.0
9 Release:        2
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/ruamel.base/
13 Source0:        https://files.pythonhosted.org/packages/source/r/ruamel.base/%{module}-%{version}.tar.gz
14 # Source0-md5:  5b2fb0e7df10672eb2a48dc329f770ee
15 URL:            https://pypi.org/project/ruamel.base/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 %if %{with python2}
19 BuildRequires:  python-modules
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules
24 BuildRequires:  python3-setuptools
25 %endif
26 Requires:       python-modules
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Common routines for ruamel packages.
31
32 %package -n python3-%{module}
33 Summary:        Common routines for ruamel packages
34 Group:          Libraries/Python
35 Requires:       python3-modules
36
37 %description -n python3-%{module}
38 Common routines for ruamel packages.
39
40 %prep
41 %setup -q -n %{module}-%{version}
42
43 %build
44 %if %{with python2}
45 %py_build
46 %endif
47
48 %if %{with python3}
49 %py3_build
50 %endif
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55
56 %if %{with python2}
57 install -d $RPM_BUILD_ROOT%{py_sitedir}/ruamel
58
59 %py_install
60
61 %py_postclean
62 %endif
63
64 %if %{with python3}
65 install -d $RPM_BUILD_ROOT%{py3_sitedir}/ruamel
66
67 %py3_install
68 %endif
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %files
75 %defattr(644,root,root,755)
76 %doc README.rst
77 %dir %{py_sitescriptdir}/ruamel
78 %{py_sitescriptdir}/ruamel/base
79 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
80 %{py_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
81 %dir %{py_sitedir}/ruamel
82 %endif
83
84 %if %{with python3}
85 %files -n python3-%{module}
86 %defattr(644,root,root,755)
87 %doc README.rst
88 %dir %{py3_sitescriptdir}/ruamel
89 %{py3_sitescriptdir}/ruamel/base
90 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
91 %{py3_sitescriptdir}/%{module}-%{version}-py*-nspkg.pth
92 %dir %{py3_sitedir}/ruamel
93 %endif
This page took 0.049542 seconds and 2 git commands to generate.