]> git.pld-linux.org Git - packages/python-rpdb.git/blob - python-rpdb.spec
- initial
[packages/python-rpdb.git] / python-rpdb.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5 #
6 %define module  rpdb
7 #
8 Summary:        pdb wrapper with remote access via tcp socket
9 Name:           python-rpdb
10 Version:        0.1.3
11 Release:        1
12 License:        ?
13 Group:          Development/Languages/Python
14 Source0:        https://pypi.python.org/packages/source/r/rpdb/rpdb-%{version}.tar.gz
15 # Source0-md5:  4f350f523446a9100395d41b0b05c6cb
16 URL:            https://pypi.python.org/pypi/rpdb/
17 %if %{with python2}
18 BuildRequires:  python-devel
19 BuildRequires:  python-modules
20 Requires:       python
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-2to3
24 BuildRequires:  python3-devel
25 BuildRequires:  python3-modules
26 %endif
27 BuildRequires:  rpm-pythonprov
28 Requires:       python-devel-src
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 A wrapper around pdb that will re-route stdin and stdout to a socket
34 handler.
35
36 %package -n     python3-%{module}
37 Summary:        pdb wrapper with remote access via tcp socket
38 Version:        0.1.3
39 Release:        1
40 Group:          Libraries/Python
41 Requires:       python3
42 Requires:       python3-devel-tools
43
44 %description -n python3-%{module}
45 A wrapper around pdb that will re-route stdin and stdout to a socket
46 handler.
47
48 %prep
49 %setup  -q -n %{module}-%{version}
50
51 %build
52 %if %{with python2}
53 %{__python} ./setup.py build --build-base py2
54 %endif
55 %if %{with python3}
56 %{__python3} ./setup.py build --build-base py3
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %if %{with python2}
62 %{__python} ./setup.py build \
63         --build-base py2 \
64         install \
65         --optimize 2 \
66         --root=$RPM_BUILD_ROOT
67 %endif
68 %if %{with python3}
69 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
70 %{__python3} ./setup.py build \
71         --build-base py3 \
72         install \
73         --optimize 2 \
74         --root=$RPM_BUILD_ROOT
75 %endif
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %if %{with python2}
81 %files
82 %defattr(644,root,root,755)
83 %doc PKG-INFO
84 %{py_sitescriptdir}/%{module}
85 %{py_sitescriptdir}/*egg-info
86 %endif
87
88 %if %{with python3}
89 %files -n python3-%{module}
90 %defattr(644,root,root,755)
91 %doc PKG-INFO
92 %{py3_sitescriptdir}/%{module}
93 %{py3_sitescriptdir}/*egg-info
94 %endif
This page took 0.096711 seconds and 3 git commands to generate.