]> git.pld-linux.org Git - packages/python-requests.git/blob - python-requests.spec
drop autogenerated deps
[packages/python-requests.git] / python-requests.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # test target (tests not included in dist tarball as of 2.13.0)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         urllib3ver      1.21.1
8 %define         module          requests
9 %define         egg_name        requests
10 %define         pypi_name       requests
11 Summary:        HTTP library for Python 2
12 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 2
13 Name:           python-%{module}
14 Version:        2.18.3
15 Release:        1
16 License:        Apache v2.0
17 Group:          Development/Languages/Python
18 Source0:        https://files.pythonhosted.org/packages/source/r/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
19 # Source0-md5:  c8f60cf816a35c0c3fef0a40d0e407a6
20 Patch0:         system-cert.patch
21 URL:            http://python-requests.org/
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.713
24 %if %{with python2}
25 BuildRequires:  python-modules >= 1:2.6
26 BuildRequires:  python-setuptools
27 %if %{with tests}
28 BuildRequires:  python-certifi >= 2017.4.17
29 BuildRequires:  python-chardet >= 3.0.2
30 BuildRequires:  python-idna >= 2.5
31 BuildRequires:  python-pytest >= 2.8.0
32 BuildRequires:  python-pytest-cov
33 BuildRequires:  python-pytest-httpbin >= 0.0.7
34 BuildRequires:  python-pytest-mock
35 BuildRequires:  python-urllib3 >= %{urllib3ver}
36 %endif
37 %endif
38 %if %{with python3}
39 BuildRequires:  python3-modules >= 1:3.2
40 %if %{with tests}
41 BuildRequires:  python3-certifi >= 2017.4.17
42 BuildRequires:  python3-chardet >= 3.0.2
43 BuildRequires:  python3-idna >= 2.5
44 BuildRequires:  python3-pytest >= 2.8.0
45 BuildRequires:  python3-pytest-cov
46 BuildRequires:  python3-pytest-httpbin >= 0.0.7
47 BuildRequires:  python3-pytest-mock
48 BuildRequires:  python3-urllib3 >= %{urllib3ver}
49 %endif
50 %endif
51 Suggests:       ca-certificates
52 # for python2 only to get SNI working. python3 doesn't need this
53 Requires:       python-ndg-httpsclient
54 Requires:       python-pyOpenSSL >= 0.14
55 Requires:       python-pyasn1
56 BuildArch:      noarch
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Requests is a HTTP library, written in Python, for human beings.
61
62 Most existing Python modules for sending HTTP requests are extremely
63 verbose and cumbersome. Python's builtin urllib2 module provides most
64 of the HTTP capabilities you should need, but the API is thoroughly
65 broken. It requires an enormous amount of work (even method overrides)
66 to perform the simplest of tasks. Things shouldn't be this way. Not in
67 Python.
68
69 This package contains Python 2.x module.
70
71 %description -l pl.UTF-8
72 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
73
74 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
75 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
76 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
77 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
78 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
79
80 Ten pakiet zawiera moduł dla Pythona 2.x.
81
82 %package -n python3-requests
83 Summary:        HTTP library for Python 3
84 Summary(pl.UTF-8):      Biblioteka HTTP dla Pythona 3
85 Group:          Development/Languages/Python
86 Suggests:       ca-certificates
87
88 %description -n python3-requests
89 Requests is a HTTP library, written in Python, for human beings.
90
91 Most existing Python modules for sending HTTP requests are extremely
92 verbose and cumbersome. Python's builtin urllib2 module provides most
93 of the HTTP capabilities you should need, but the api is thoroughly
94 broken. It requires an enormous amount of work (even method overrides)
95 to perform the simplest of tasks. Things shouldn't be this way. Not in
96 Python.
97
98 This package contains Python 3.x module.
99
100 %description -n python3-requests -l pl.UTF-8
101 Requests to napisana w Pythonie biblioteka HTTP dla ludzi.
102
103 Większość istniejących modułów Pythona do wysyłania żądań HTTP jest
104 zbyt gadatliwa i nieporęczna. Wbudowany w Pythona moduł urllib2
105 zapewnia większość wymaganych możliwości HTTP, ale API jest kiepskie -
106 wymaga dużych nakładów pracy (nawet nadpisań metod) do wykonania
107 najprostszych zadań. Nie powinno tak być. Nie w Pythonie.
108
109 Ten pakiet zawiera moduł dla Pythona 3.x.
110
111 %prep
112 %setup -q -n %{module}-%{version}
113 %patch0 -p1
114
115 %build
116 %if %{with python2}
117 %py_build %{?with_tests:test}
118 %endif
119
120 %if %{with python3}
121 %py3_build %{?with_tests:test}
122 %endif
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %if %{with python2}
128 %py_install
129 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
130 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
131 %py_postclean
132 %endif
133
134 %if %{with python3}
135 %py3_install
136 %endif
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %if %{with python2}
142 %files
143 %defattr(644,root,root,755)
144 %doc HISTORY.rst README.rst
145 %{py_sitescriptdir}/%{module}
146 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
147 %endif
148
149 %if %{with python3}
150 %files -n python3-requests
151 %defattr(644,root,root,755)
152 %doc HISTORY.rst README.rst
153 %{py3_sitescriptdir}/%{module}
154 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
155 %endif
This page took 0.0805439999999999 seconds and 4 git commands to generate.