]> git.pld-linux.org Git - packages/python-repoze.sphinx.autointerface.git/blob - python-repoze.sphinx.autointerface.spec
e38f72621384be26e37d9de2853ac013d3dc9ada
[packages/python-repoze.sphinx.autointerface.git] / python-repoze.sphinx.autointerface.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Sphinx extension: auto-generate API docs from Zope interfaces
7 Summary(pl.UTF-8):      Rozszerzenie Sphinksa: automatyczne generowanie dokumentacji API z interfejsów Zope
8 Name:           python-repoze.sphinx.autointerface
9 Version:        0.8
10 Release:        3
11 License:        BSD-like
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/repoze-sphinx-autointerface/
14 Source0:        https://files.pythonhosted.org/packages/source/r/repoze.sphinx.autointerface/repoze.sphinx.autointerface-%{version}.tar.gz
15 # Source0-md5:  8e05cb8421b0a3bea8ec3b0aa3695310
16 URL:            https://pypi.org/project/repoze.sphinx.autointerface/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.3
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.7
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This package defines an extension for the Sphinx documentation system.
33 The extension allows generation of API documentation by introspection
34 of zope.interface instances in code.
35
36 %description -l pl.UTF-8
37 Ten pakiet definiuje rozszerzenie systemu dokumentacji Sphinx,
38 pozwalające generować dokumentację API poprzez wgląd w instancje
39 zope.interface w kodzie.
40
41 %package -n python3-repoze.sphinx.autointerface
42 Summary:        Sphinx extension: auto-generate API docs from Zope interfaces
43 Summary(pl.UTF-8):      Rozszerzenie Sphinksa: automatyczne generowanie dokumentacji API z interfejsów Zope
44 Group:          Libraries/Python
45 Requires:       python3-modules >= 1:3.3
46
47 %description -n python3-repoze.sphinx.autointerface
48 This package defines an extension for the Sphinx documentation system.
49 The extension allows generation of API documentation by introspection
50 of zope.interface instances in code.
51
52 %description -n python3-repoze.sphinx.autointerface -l pl.UTF-8
53 Ten pakiet definiuje rozszerzenie systemu dokumentacji Sphinx,
54 pozwalające generować dokumentację API poprzez wgląd w instancje
55 zope.interface w kodzie.
56
57 %prep
58 %setup -q -n repoze.sphinx.autointerface-%{version}
59
60 %build
61 %if %{with python2}
62 %py_build
63 %endif
64
65 %if %{with python3}
66 %py3_build
67 %endif
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %if %{with python2}
73 %py_install
74
75 %py_postclean
76 %endif
77
78 %if %{with python3}
79 %py3_install
80 %endif
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with python2}
86 %files
87 %defattr(644,root,root,755)
88 %doc CHANGES.rst CONTRIBUTORS.txt COPYRIGHT.txt LICENSE.txt README.rst TODO.txt
89 # XXX: shared dir
90 %dir %{py_sitescriptdir}/repoze
91 %dir %{py_sitescriptdir}/repoze/sphinx
92 %{py_sitescriptdir}/repoze/sphinx/autointerface.py[co]
93 %{py_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*.egg-info
94 %{py_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*-nspkg.pth
95 %endif
96
97 %if %{with python3}
98 %files -n python3-repoze.sphinx.autointerface
99 %defattr(644,root,root,755)
100 %doc CHANGES.rst CONTRIBUTORS.txt COPYRIGHT.txt LICENSE.txt README.rst TODO.txt
101 %dir %{py3_sitescriptdir}/repoze
102 %dir %{py3_sitescriptdir}/repoze/sphinx
103 %{py3_sitescriptdir}/repoze/sphinx/autointerface.py
104 %{py3_sitescriptdir}/repoze/sphinx/__pycache__
105 %{py3_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*.egg-info
106 %{py3_sitescriptdir}/repoze.sphinx.autointerface-%{version}-py*-nspkg.pth
107 %endif
This page took 0.059569 seconds and 2 git commands to generate.