]> git.pld-linux.org Git - packages/python-reno.git/blob - python-reno.spec
- updated to 2.11.3
[packages/python-reno.git] / python-reno.spec
1 # TODO: fix tests and doc
2 #
3 # Conditional build:
4 %bcond_with     doc     # Sphinx documentation [broken, requires git repo?]
5 %bcond_with     tests   # subunit tests (requires git repo?)
6 %bcond_without  python2 # CPython 2.x module
7 %bcond_without  python3 # CPython 3.x module
8
9 Summary:        reno: a New Way to manage Release Notes
10 Summary(pl.UTF-8):      reno: nowy sposób zarządzania informacjami o wydaniu (Release Notes)
11 Name:           python-reno
12 Version:        2.11.3
13 Release:        1
14 License:        Apache v2.0
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.python.org/simple/reno
17 Source0:        https://files.pythonhosted.org/packages/source/r/reno/reno-%{version}.tar.gz
18 # Source0-md5:  c582cf344169a91f8d9a86b22ae3660a
19 Patch0:         %{name}-mock.patch
20 URL:            http://docs.openstack.org/developer/reno/
21 %if %{with python2}
22 BuildRequires:  python-modules >= 1:2.7
23 BuildRequires:  python-pbr >= 1.4
24 BuildRequires:  python-setuptools
25 %if %{with tests}
26 BuildRequires:  python-PyYAML >= 3.10.0
27 BuildRequires:  python-Sphinx >= 1.6.1
28 BuildRequires:  python-coverage >= 4.0
29 BuildRequires:  python-dulwich >= 0.15.0
30 BuildRequires:  python-mock >= 1.2
31 BuildRequires:  python-six >= 1.9.0
32 BuildRequires:  python-testtools >= 1.4.0
33 %endif
34 %endif
35 %if %{with python3}
36 BuildRequires:  python3-modules >= 1:3.4
37 BuildRequires:  python3-pbr >= 1.4
38 BuildRequires:  python3-setuptools
39 %if %{with tests}
40 BuildRequires:  python3-PyYAML >= 3.10.0
41 BuildRequires:  python3-Sphinx >= 1.6.1
42 BuildRequires:  python3-coverage >= 4.0
43 BuildRequires:  python3-dulwich >= 0.15.0
44 BuildRequires:  python3-six >= 1.9.0
45 BuildRequires:  python3-testtools >= 1.4.0
46 %endif
47 %endif
48 %if %{with doc}
49 BuildRequires:  python3-docutils >= 0.11
50 BuildRequires:  python3-openstackdocstheme >= 1.11.0
51 BuildRequires:  sphinx-pdg >= 1.6.1
52 %endif
53 BuildRequires:  rpm-pythonprov
54 BuildRequires:  rpmbuild(macros) >= 1.714
55 Requires:       python-modules >= 1:2.7
56 BuildArch:      noarch
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 Reno is a release notes manager designed with high throughput in mind,
61 supporting fast distributed development teams without introducing
62 additional development processes. The goal is to encourage detailed
63 and accurate release notes for every release.
64
65 %description -l pl.UTF-8
66 Reno to zarządca informacji o wydaniu, zaprojektowany z myślą o dużym
67 przepływie, obsługujący szybkie, rozproszone zespoły programistów bez
68 wprowadzania dodatkowych procesów. Celem jest wspieranie szczegółowych
69 i dokładnych informacji dla każdego wydania.
70
71 %package -n python3-reno
72 Summary:        reno: a New Way to manage Release Notes
73 Summary(pl.UTF-8):      reno: nowy sposób zarządzania informacjami o wydaniu (Release Notes)
74 Group:          Libraries/Python
75 Requires:       python3-modules >= 1:3.4
76
77 %description -n python3-reno
78 Reno is a release notes manager designed with high throughput in mind,
79 supporting fast distributed development teams without introducing
80 additional development processes. The goal is to encourage detailed
81 and accurate release notes for every release.
82
83 %description -n python3-reno -l pl.UTF-8
84 Reno to zarządca informacji o wydaniu, zaprojektowany z myślą o dużym
85 przepływie, obsługujący szybkie, rozproszone zespoły programistów bez
86 wprowadzania dodatkowych procesów. Celem jest wspieranie szczegółowych
87 i dokładnych informacji dla każdego wydania.
88
89 %package apidocs
90 Summary:        API documentation for reno
91 Summary(pl.UTF-8):      Dokumentacja API modułu reno
92 Group:          Documentation
93
94 %description apidocs
95 API documentation for reno.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API modułu reno.
99
100 %prep
101 %setup -q -n reno-%{version}
102 %patch0 -p1
103
104 %build
105 %if %{with python2}
106 %py_build
107
108 %if %{with tests}
109 %{__python} -m unittest discover -s reno/tests
110 %endif
111 %endif
112
113 %if %{with python3}
114 %py3_build
115
116 %if %{with tests}
117 %{__python3} -m unittest discover -s reno/tests
118 %endif
119 %endif
120
121 %if %{with doc}
122 PYTHONPATH=$(pwd) \
123 sphinx-build-3 -b html doc/source doc/source/_build/html
124 %endif
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %if %{with python2}
130 %py_install
131
132 %{__mv} $RPM_BUILD_ROOT%{_bindir}/reno{,-2}
133
134 %py_postclean
135 %endif
136
137 %if %{with python3}
138 %py3_install
139
140 %{__mv} $RPM_BUILD_ROOT%{_bindir}/reno{,-3}
141 ln -s reno-3 $RPM_BUILD_ROOT%{_bindir}/reno
142 %endif
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %if %{with python2}
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog README.rst
151 %attr(755,root,root) %{_bindir}/reno-2
152 %{py_sitescriptdir}/reno
153 %{py_sitescriptdir}/reno-%{version}-py*.egg-info
154 %endif
155
156 %if %{with python3}
157 %files -n python3-reno
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog README.rst
160 %attr(755,root,root) %{_bindir}/reno
161 %attr(755,root,root) %{_bindir}/reno-3
162 %{py3_sitescriptdir}/reno
163 %{py3_sitescriptdir}/reno-%{version}-py*.egg-info
164 %endif
165
166 %if %{with doc}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %doc docs/_build/html/*
170 %endif
This page took 0.079788 seconds and 3 git commands to generate.