]> git.pld-linux.org Git - packages/python-recaptcha.git/blob - python-recaptcha.spec
- release 3
[packages/python-recaptcha.git] / python-recaptcha.spec
1 %define         fname   recaptcha-client
2 Summary:        A client for reCAPTCHA and reCAPTCHA Mailhide
3 Summary(pl.UTF-8):      Klient usług reCAPTCHA i reCAPTCHA Mailhide
4 Name:           python-recaptcha
5 Version:        1.0.3
6 Release:        3
7 License:        MIT
8 Group:          Libraries/Python
9 Source0:        http://pypi.python.org/packages/source/r/recaptcha-client/%{fname}-%{version}.tar.gz
10 # Source0-md5:  5aaa88d703f1003ecc63a0ced00baad6
11 URL:            http://recaptcha.net
12 BuildRequires:  python >= 1:2.5
13 BuildRequires:  python-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 %pyrequires_eq  python-modules
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Provides a CAPTCHA for Python using the reCAPTCHA service. Does not
22 require any imaging libraries because the CAPTCHA is served directly
23 from reCAPTCHA. Also allows you to securely obfuscate emails with
24 Mailhide. This functionality requires pycrypto. This library requires
25 two types of API keys. If you'd like to use the CAPTCHA, you'll need
26 a key from <http://recaptcha.net/api/getkey>. For Mailhide, you'll
27 need a key from <http://mailhide.recaptcha.net/apikey>.
28
29 %description -l pl.UTF-8
30 Ten moduł obsługuje CAPTCHA (kod do wpisania z obrazka) w Pythonie w
31 oparciu o usługę reCAPTCHA. Nie wymaga żadnaj biblioteki graficznej,
32 gdyż CAPTCHA serwowana jest bezpośrednio z reCAPTCHA. Pozwala również
33 bezpiecznie ukryć adresy email za pomocą Mailhide. Ta funkcjonalność
34 wymaga pycrypto. Do działania klienta niezbędne są dwa klucze. Aby
35 używać CAPTCHA, należy pobrać klucz ze strony
36 <http://recaptcha.net/api/getkey>. Dla Mailhide należy pobrać klucz ze
37 strony <http://mailhide.recaptcha.net/apikey>.
38
39 %prep
40 %setup -qn %{fname}-%{version}
41
42 %build
43 %{__python} setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__python} setup.py install \
48         --root=$RPM_BUILD_ROOT \
49         --optimize=2
50
51 # structure of this module is an incredible fuckup. anyone knows how to fix this?
52 cp recaptcha/__init__.pyc $RPM_BUILD_ROOT%{py_sitescriptdir}/recaptcha
53
54 %py_postclean
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %{py_sitescriptdir}/recaptcha
62 %{py_sitescriptdir}/recaptcha_client-%{version}-py*.egg-info
This page took 0.043956 seconds and 3 git commands to generate.