]> git.pld-linux.org Git - packages/python-recaptcha.git/blob - python-recaptcha.spec
0e924bafcedf8339cc999b963859eb2d42d5599f
[packages/python-recaptcha.git] / python-recaptcha.spec
1 %define         fname   recaptcha-client
2 Summary:        A client for reCAPTCHA and reCAPTCHA Mailhide
3 Summary(pl.UTF-8):      Klient usług reCAPTCHA i reCAPTCHA Mailhide
4 Name:           python-recaptcha
5 Version:        1.0.6
6 Release:        2
7 License:        MIT
8 Group:          Libraries/Python
9 Source0:        http://pypi.python.org/packages/source/r/recaptcha-client/%{fname}-%{version}.tar.gz
10 # Source0-md5:  74228180f7e1fb76c4d7089160b0d919
11 URL:            http://www.google.com/recaptcha
12 BuildRequires:  python >= 1:2.5
13 BuildRequires:  python-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 Requires:       python-modules
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Provides a CAPTCHA for Python using the reCAPTCHA service. Does not
22 require any imaging libraries because the CAPTCHA is served directly
23 from reCAPTCHA. Also allows you to securely obfuscate emails with
24 Mailhide. This functionality requires pycrypto. This library requires
25 two types of API keys. If you'd like to use the CAPTCHA, you'll need
26 a key from <http://recaptcha.net/api/getkey>. For Mailhide, you'll
27 need a key from <http://mailhide.recaptcha.net/apikey>.
28
29 %description -l pl.UTF-8
30 Ten moduł obsługuje CAPTCHA (kod do wpisania z obrazka) w Pythonie w
31 oparciu o usługę reCAPTCHA. Nie wymaga żadnaj biblioteki graficznej,
32 gdyż CAPTCHA serwowana jest bezpośrednio z reCAPTCHA. Pozwala również
33 bezpiecznie ukryć adresy email za pomocą Mailhide. Ta funkcjonalność
34 wymaga pycrypto. Do działania klienta niezbędne są dwa klucze. Aby
35 używać CAPTCHA, należy pobrać klucz ze strony
36 <http://recaptcha.net/api/getkey>. Dla Mailhide należy pobrać klucz ze
37 strony <http://mailhide.recaptcha.net/apikey>.
38
39 %prep
40 %setup -qn %{fname}-%{version}
41
42 %build
43 %{__python} setup.py build
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__python} setup.py install \
48         --skip-build \
49         --optimize=2 \
50         --root=$RPM_BUILD_ROOT
51
52 %py_postclean
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{py_sitescriptdir}/recaptcha
60 %{py_sitescriptdir}/recaptcha_client-%{version}-py*.egg-info
This page took 0.097174 seconds and 3 git commands to generate.