]> git.pld-linux.org Git - packages/python-rdflib.git/blob - python-rdflib.spec
rebuild with python 3.10
[packages/python-rdflib.git] / python-rdflib.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define module  rdflib
7
8 Summary:        Python 2 library for working with RDF
9 Summary(pl.UTF-8):      Biblioteka Pythona 2 do pracy z RDF
10 Name:           python-%{module}
11 Version:        4.2.2
12 Release:        4
13 License:        BSD
14 Group:          Development/Languages/Python
15 Source0:        https://github.com/RDFLib/rdflib/archive/%{version}/%{module}-%{version}.tar.gz
16 # Source0-md5:  1dd95c6443302d6a44a908e4af8fdc5d
17 URL:            https://github.com/RDFLib/rdflib
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.3
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.6
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 RDFLib is a Python library for working with RDF, a simple yet powerful
34 language for representing information. The library contains an RDF/XML
35 parser/serializer, a TripleStore, an InformationStore and various
36 store backends. It is being developed by Daniel Krech along with the
37 help of a number of contributors.
38
39 %description -l pl.UTF-8
40 RDFLib to biblioteka Pythona do pracy z RDF - prostym, ale potężnym
41 językiem do reprezentowania informacji. Biblioteka zawiera
42 parser/serializer RDF/XML, TripleStore, InformationStore oraz różne
43 backendy do przechowywania informacji. Jest rozwijana przez Daniela
44 Krecha z pomocą wielu współpracowników.
45
46 %package -n python3-%{module}
47 Summary:        Python 3 library for working with RDF
48 Summary(pl.UTF-8):      Biblioteka Pythona 3 do pracy z RDF
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.3
51
52 %description -n python3-%{module}
53 RDFLib is a Python library for working with RDF, a simple yet powerful
54 language for representing information. The library contains an RDF/XML
55 parser/serializer, a TripleStore, an InformationStore and various
56 store backends. It is being developed by Daniel Krech along with the
57 help of a number of contributors.
58
59 %description -n python3-%{module} -l pl.UTF-8
60 RDFLib to biblioteka Pythona do pracy z RDF - prostym, ale potężnym
61 językiem do reprezentowania informacji. Biblioteka zawiera
62 parser/serializer RDF/XML, TripleStore, InformationStore oraz różne
63 backendy do przechowywania informacji. Jest rozwijana przez Daniela
64 Krecha z pomocą wielu współpracowników.
65
66 %package -n rdflib-tools
67 Summary:        Utilities from python-rdflib
68 Summary(pl.UTF-8):      Narzędzia z pakietu python-rdflib
69 Group:          Applications/File
70 %if %{with python3}
71 Requires:       python3-%{module} = %{version}-%{release}
72 %else
73 Requires:       %{name} = %{version}-%{release}
74 %endif
75
76 %description -n rdflib-tools
77 Utilities from python-rdflib.
78
79 %description -n rdflib-tools -l pl.UTF-8
80 Narzędzia z pakietu python-rdflib.
81
82 %prep
83 %setup -q -n %{module}-%{version}
84
85 %build
86 %if %{with python2}
87 %py_build %{?with_tests:test}
88 %endif
89
90 %if %{with python3}
91 %py3_build %{?with_tests:test}
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %py_install
99
100 %py_postclean
101
102 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103 cp -p examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
104 %endif
105
106 %if %{with python3}
107 %py3_install
108
109 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
110 cp -p examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc CHANGELOG.md CONTRIBUTORS LICENSE README.md
119 %{py_sitescriptdir}/rdflib
120 %{py_sitescriptdir}/rdflib-%{version}-py*.egg-info
121 %{_examplesdir}/%{name}-%{version}
122
123 %files -n python3-%{module}
124 %defattr(644,root,root,755)
125 %doc CHANGELOG.md CONTRIBUTORS LICENSE README.md
126 %{py3_sitescriptdir}/rdflib
127 %{py3_sitescriptdir}/rdflib-%{version}-py*.egg-info
128 %{_examplesdir}/python3-%{module}-%{version}
129
130 %files -n rdflib-tools
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/csv2rdf
133 %attr(755,root,root) %{_bindir}/rdf2dot
134 %attr(755,root,root) %{_bindir}/rdfgraphisomorphism
135 %attr(755,root,root) %{_bindir}/rdfpipe
136 %attr(755,root,root) %{_bindir}/rdfs2dot
This page took 0.075949 seconds and 3 git commands to generate.