]> git.pld-linux.org Git - packages/python-rdflib.git/blob - python-rdflib.spec
Version: 4.2.1, python3 support
[packages/python-rdflib.git] / python-rdflib.spec
1
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define module  rdflib
7
8 Summary:        Python library for working with RDF
9 Summary(pl.UTF-8):      Biblioteka Pythona do pracy z RDF
10 Name:           python-%{module}
11 Version:        4.2.1
12 Release:        1
13 License:        BSD
14 Group:          Development/Languages/Python
15 Source0:        https://github.com/RDFLib/rdflib/archive/%{version}/%{module}-%{version}.tar.gz
16 # Source0-md5:  ce76cb39a5737aeb99f557cff3826a5f
17 URL:            https://github.com/RDFLib/rdflib
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 RDFLib is a Python library for working with RDF, a simple yet powerful
34 language for representing information. The library contains an RDF/XML
35 parser/serializer, a TripleStore, an InformationStore and various
36 store backends. It is being developed by Daniel Krech along with the
37 help of a number of contributors.
38
39 %description -l pl.UTF-8
40 RDFLib to biblioteka Pythona do pracy z RDF - prostym, ale potężnym
41 językiem do reprezentowania informacji. Biblioteka zawiera
42 parser/serializer RDF/XML, TripleStore, InformationStore oraz różne
43 backendy do przechowywania informacji. Jest rozwijana przez Daniela
44 Krecha z pomocą wielu współpracowników.
45
46 %package -n python3-%{module}
47 Summary:        Python library for working with RDF
48 Summary(pl.UTF-8):      Biblioteka Pythona do pracy z RDF
49 Group:          Libraries/Python
50 Requires:       python3-modules
51
52 %description -n python3-%{module}
53 RDFLib is a Python library for working with RDF, a simple yet powerful
54 language for representing information. The library contains an RDF/XML
55 parser/serializer, a TripleStore, an InformationStore and various
56 store backends. It is being developed by Daniel Krech along with the
57 help of a number of contributors.
58
59 %description -n python3-%{module} -l pl.UTF-8
60 RDFLib to biblioteka Pythona do pracy z RDF - prostym, ale potężnym
61 językiem do reprezentowania informacji. Biblioteka zawiera
62 parser/serializer RDF/XML, TripleStore, InformationStore oraz różne
63 backendy do przechowywania informacji. Jest rozwijana przez Daniela
64 Krecha z pomocą wielu współpracowników.
65
66 %package -n rdflib-tools
67 Summary:        Utilities from python-rdflib
68 Group:          Applications
69 %if %{with python3}
70 Requires:       python3-%{module}
71 %else
72 Requires:       %{name}
73 %endif
74
75 %description -n rdflib-tools
76 Utilities from python-rdflib.
77
78 %prep
79 %setup -q -n %{module}-%{version}
80
81 %build
82 %if %{with python2}
83 %py_build %{?with_tests:test}
84 %endif
85
86 %if %{with python3}
87 %py3_build %{?with_tests:test}
88 %endif
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %if %{with python2}
94 %py_install
95
96 %py_postclean
97 %endif
98
99 %if %{with python3}
100 %py3_install
101 %endif
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %files
107 %defattr(644,root,root,755)
108 %doc CHANGELOG.md README.md CONTRIBUTORS examples/*.py
109 %{py_sitescriptdir}/rdflib
110 %{py_sitescriptdir}/rdflib-*.egg-info
111
112 %files -n python3-%{module}
113 %defattr(644,root,root,755)
114 %doc CHANGELOG.md README.md CONTRIBUTORS examples/*.py
115 %{py3_sitescriptdir}/rdflib
116 %{py3_sitescriptdir}/rdflib-*.egg-info
117
118 %files -n rdflib-tools
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/*
This page took 0.032004 seconds and 3 git commands to generate.