]> git.pld-linux.org Git - packages/python-railroad-diagrams.git/blob - python-railroad-diagrams.spec
dc8ef09b3071966eafbf5ba361aa354779395d47
[packages/python-railroad-diagrams.git] / python-railroad-diagrams.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Generate SVG railroad syntax diagrams, like on JSON.org
7 Summary(pl.UTF-8):      Generowanie diagramów składniowych SVG, jak na JSON.org
8 Name:           python-railroad-diagrams
9 Version:        1.1.1
10 Release:        2
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/railroad-diagrams/
14 Source0:        https://files.pythonhosted.org/packages/source/r/railroad-diagrams/railroad-diagrams-%{version}.tar.gz
15 # Source0-md5:  594e2552106be714d01adbfd4329c274
16 URL:            https://pypi.org/project/railroad-diagrams/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.4
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.7
28 # "railroad" dir shadows railroad.py
29 Conflicts:      python-railroad
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This is a small library for generating railroad diagrams (like what
35 JSON.org uses) using SVG, with both JS and Python ports.
36
37 %description -l pl.UTF-8
38 Mała biblioteka do generowania diagramów składniowych (podobnych do
39 tych, których używa JSON.org) przy użyciu SVG, mająca porty w JS i
40 Pythonie.
41
42 %package -n python3-railroad-diagrams
43 Summary:        Generate SVG railroad syntax diagrams, like on JSON.org
44 Summary(pl.UTF-8):      Generowanie diagramów składniowych SVG, jak na JSON.org
45 Group:          Libraries/Python
46 Requires:       python3-modules >= 1:3.4
47 # "railroad" dir shadows railroad.py
48 Conflicts:      python3-railroad
49
50 %description -n python3-railroad-diagrams
51 This is a small library for generating railroad diagrams (like what
52 JSON.org uses) using SVG, with both JS and Python ports.
53
54 %description -n python3-railroad-diagrams -l pl.UTF-8
55 Mała biblioteka do generowania diagramów składniowych (podobnych do
56 tych, których używa JSON.org) przy użyciu SVG, mająca porty w JS i
57 Pythonie.
58
59 %package apidocs
60 Summary:        API documentation for Python railroad-diagrams module
61 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona railroad-diagrams
62 Group:          Documentation
63
64 %description apidocs
65 API documentation for Python railroad-diagrams module.
66
67 %description apidocs -l pl.UTF-8
68 Dokumentacja API modułu Pythona railroad-diagrams.
69
70 %prep
71 %setup -q -n railroad-diagrams-%{version}
72
73 %build
74 %if %{with python2}
75 %py_build
76 %endif
77
78 %if %{with python3}
79 %py3_build
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %if %{with python2}
86 %py_install
87
88 %py_postclean
89 %endif
90
91 %if %{with python3}
92 %py3_install
93 %endif
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %if %{with python2}
99 %files
100 %defattr(644,root,root,755)
101 %doc README.md README-py.md
102 %{py_sitescriptdir}/railroad.py[co]
103 %{py_sitescriptdir}/railroad_diagrams-%{version}-py*.egg-info
104 %endif
105
106 %if %{with python3}
107 %files -n python3-railroad-diagrams
108 %defattr(644,root,root,755)
109 %doc README.md README-py.md
110 %{py3_sitescriptdir}/railroad.py
111 %{py3_sitescriptdir}/__pycache__/railroad.cpython-*.py[co]
112 %{py3_sitescriptdir}/railroad_diagrams-%{version}-py*.egg-info
113 %endif
This page took 0.090634 seconds and 2 git commands to generate.