]> git.pld-linux.org Git - packages/python-pyxdg.git/blob - python-pyxdg.spec
- updated to 0.26
[packages/python-pyxdg.git] / python-pyxdg.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  pyxdg
7 Summary:        Python 2 implementations of freedesktop.org standards
8 Summary(pl.UTF-8):      Implementacje standardów freedesktop.org w języku Python 2
9 Name:           python-%{module}
10 Version:        0.26
11 Release:        1
12 License:        LGPL v2
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pyxdg/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pyxdg/%{module}-%{version}.tar.gz
16 # Source0-md5:  db1c2af8300ca64ce3955b3cf2490c92
17 URL:            https://freedesktop.org/wiki/Software/pyxdg/
18 %{?with_python2:BuildRequires:  python-devel >= 1:2.6}
19 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 Requires:       python-modules >= 1:2.6
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 PyXDG is a Python module to access freedesktop.org standards. The
28 package contains:
29
30  - Implementation of the XDG-Base-Directory Standard
31  - Implementation of the XDG-Desktop Standard
32  - Implementation of the XDG-Menu Standard
33  - Implementation of the XDG-Icon-Theme Standard
34  - Implementation of the XDG-Shared MIME-info Database
35  - Implementation of the XDG-Recent File Storage Specification
36
37 %description -l pl.UTF-8
38 PyXDG jest modułem języka Python, pozwalającym na wykorzystywanie
39 standardów freedesktop.org. Pakiet zawiera:
40
41  - Implementację standardu XDG-Base-Directory
42  - Implementację standardu XDG-Desktop
43  - Implementację standardu XDG-Menu
44  - Implementację standardu XDG-Icon-Theme
45  - Implementację bazy XDG-Shared MIME-info
46  - Implementację specyfikacji XDG-Recent File Storage
47
48 %package -n python3-pyxdg
49 Summary:        Python 3 implementations of freedesktop.org standards
50 Summary(pl.UTF-8):      Implementacje standardów freedesktop.org w języku Python 3
51 Group:          Libraries/Python
52 Requires:       python3-modules >= 1:3.2
53
54 %description -n python3-pyxdg
55 PyXDG is a Python module to access freedesktop.org standards. The
56 package contains:
57
58  - Implementation of the XDG-Base-Directory Standard
59  - Implementation of the XDG-Desktop Standard
60  - Implementation of the XDG-Menu Standard
61  - Implementation of the XDG-Icon-Theme Standard
62  - Implementation of the XDG-Shared MIME-info Database
63  - Implementation of the XDG-Recent File Storage Specification
64
65 %description -n python3-pyxdg -l pl.UTF-8
66 PyXDG jest modułem języka Python, pozwalającym na wykorzystywanie
67 standardów freedesktop.org. Pakiet zawiera:
68
69  - Implementację standardu XDG-Base-Directory
70  - Implementację standardu XDG-Desktop
71  - Implementację standardu XDG-Menu
72  - Implementację standardu XDG-Icon-Theme
73  - Implementację bazy XDG-Shared MIME-info
74  - Implementację specyfikacji XDG-Recent File Storage
75
76 %prep
77 %setup -q -n %{module}-%{version}
78
79 %build
80 %if %{with python2}
81 %py_build
82 %endif
83
84 %if %{with python3}
85 %py3_build
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{with python2}
92 %py_install
93 %py_postclean
94 %endif
95
96 %if %{with python3}
97 %py3_install
98 %endif
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %if %{with python2}
104 %files
105 %defattr(644,root,root,755)
106 %doc AUTHORS ChangeLog README TODO
107 %dir %{py_sitescriptdir}/xdg
108 %{py_sitescriptdir}/xdg/*.py[co]
109 %{py_sitescriptdir}/pyxdg-%{version}-py*.egg-info
110 %endif
111
112 %if %{with python3}
113 %files -n python3-pyxdg
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog README TODO
116 %dir %{py3_sitescriptdir}/xdg
117 %{py3_sitescriptdir}/xdg/*.py
118 %{py3_sitescriptdir}/xdg/__pycache__
119 %{py3_sitescriptdir}/pyxdg-%{version}-py*.egg-info
120 %endif
This page took 0.049679 seconds and 3 git commands to generate.