]> git.pld-linux.org Git - packages/python-pyuca.git/blob - python-pyuca.spec
- python 3.6
[packages/python-pyuca.git] / python-pyuca.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't build doc
4 %bcond_without  tests   # do not perform "make test"
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_without  python3 # CPython 3.x module
7
8 %define         module          pyuca
9 %define         egg_name        pyuca
10 %define         pypi_name       pyuca
11 Summary:        A Python implementation of the Unicode Collation Algorithm
12 Name:           python-%{module}
13 Version:        1.1
14 Release:        2
15 License:        MIT
16 Group:          Libraries/Python
17 Source0:        https://files.pythonhosted.org/packages/source/p/%{module}/%{module}-%{version}.tar.gz
18 # Source0-md5:  23139a4c470c56e74da1210baf0da6ba
19 URL:            http://github.com/jtauber/pyuca
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 %if %{with python2}
23 BuildRequires:  python-devel
24 BuildRequires:  python-setuptools
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-devel
28 BuildRequires:  python3-setuptools
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A Python implementation of the Unicode Collation Algorithm.
35
36 %package -n python3-%{pypi_name}
37 Summary:        A Python implementation of the Unicode Collation Algorithm
38 Group:          Libraries/Python
39
40 %description -n python3-%{pypi_name}
41 A Python implementation of the Unicode Collation Algorithm.
42
43 %prep
44 %setup -q -n %{module}-%{version}
45
46 # Remove bundled egg-info
47 %{__rm} -r %{module}.egg-info
48
49 %build
50 %if %{with python2}
51 %py_build %{?with_tests:test}
52 %endif
53
54 %if %{with python3}
55 %py3_build %{?with_tests:test}
56 %endif
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %if %{with python2}
62 %py_install
63 %py_postclean
64 %endif
65
66 %if %{with python3}
67 %py3_install
68 %endif
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %files
75 %defattr(644,root,root,755)
76 %doc
77 %{py_sitescriptdir}/%{pypi_name}
78 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
79 %endif
80
81 %if %{with python3}
82 %files -n python3-%{pypi_name}
83 %defattr(644,root,root,755)
84 %doc
85 %{py3_sitescriptdir}/%{pypi_name}
86 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
87 %endif
This page took 0.063083 seconds and 3 git commands to generate.