]> git.pld-linux.org Git - packages/python-pytest-freezegun.git/blob - python-pytest-freezegun.spec
7ef8f81dfa0c9bcb3386d9ac6c61d426d257646b
[packages/python-pytest-freezegun.git] / python-pytest-freezegun.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Wrap tests with fixtures in freeze_time
8 Summary(pl.UTF-8):      Obudowywanie testów z wyposażeniem w zamrożonym czasie
9 Name:           python-pytest-freezegun
10 # keep 0.3.x here for python2 support
11 Version:        0.3.0.post1
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/pytest-freezegun/
16 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-freezegun/pytest-freezegun-%{version}.zip
17 # Source0-md5:  2bf9d50fa0c78d20c193e7ded635bc2f
18 URL:            https://pypi.org/project/pytest-freezegun/
19 %if %{with python2}
20 BuildRequires:  python-modules >= 1:2.7
21 BuildRequires:  python-setuptools
22 %if %{with tests}
23 BuildRequires:  python-freezegun >= 0.3
24 BuildRequires:  python-pytest >= 3.0.0
25 %endif
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-modules >= 1:3.4
29 BuildRequires:  python3-setuptools
30 %if %{with tests}
31 BuildRequires:  python3-freezegun >= 0.3
32 BuildRequires:  python3-pytest >= 3.0.0
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 Requires:       python-modules >= 1:2.7
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Wrap tests with fixtures in freeze_time.
43
44 %description -l pl.UTF-8
45 Obudowywanie testów z wyposażeniem w czasie zamrożonym przez
46 freeze_time.
47
48 %package -n python3-pytest-freezegun
49 Summary:        Wrap tests with fixtures in freeze_time
50 Summary(pl.UTF-8):      Obudowywanie testów z wyposażeniem w zamrożonym czasie
51 Group:          Libraries/Python
52 Requires:       python3-modules >= 1:3.4
53
54 %description -n python3-pytest-freezegun
55 Wrap tests with fixtures in freeze_time.
56
57 %description -n python3-pytest-freezegun -l pl.UTF-8
58 Obudowywanie testów z wyposażeniem w czasie zamrożonym przez
59 freeze_time.
60
61 %prep
62 %setup -q -n pytest-freezegun-%{version}
63
64 %build
65 %if %{with python2}
66 %py_build
67 %endif
68
69 %if %{with python3}
70 %py3_build
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %if %{with python2}
77 %py_install
78
79 %py_postclean
80 %endif
81
82 %if %{with python3}
83 %py3_install
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with python2}
90 %files
91 %defattr(644,root,root,755)
92 %doc LICENSE README.rst
93 %{py_sitescriptdir}/pytest_freezegun.py[co]
94 %{py_sitescriptdir}/pytest_freezegun-%{version}-py*.egg-info
95 %endif
96
97 %if %{with python3}
98 %files -n python3-pytest-freezegun
99 %defattr(644,root,root,755)
100 %doc LICENSE README.rst
101 %{py3_sitescriptdir}/pytest_freezegun.py
102 %{py3_sitescriptdir}/__pycache__/pytest_freezegun.cpython-*.py[co]
103 %{py3_sitescriptdir}/pytest_freezegun-%{version}-py*.egg-info
104 %endif
This page took 0.06219 seconds and 2 git commands to generate.