]> git.pld-linux.org Git - packages/python-pytest-freezegun.git/blob - python-pytest-freezegun.spec
- disable python3 here
[packages/python-pytest-freezegun.git] / python-pytest-freezegun.spec
1 # NOTE: for versions >= 0.4.0 (for Python 3.5+) see python3-pytest-freezegun.spec
2 #
3 # Conditional build:
4 %bcond_with     tests   # unit tests (not included in sdist)
5 %bcond_without  python2 # CPython 2.x module
6 %bcond_with     python3 # CPython 3.x module (built from python3-pytest-freezegun.spec)
7
8 Summary:        Wrap tests with fixtures in freeze_time
9 Summary(pl.UTF-8):      Obudowywanie testów z wyposażeniem w zamrożonym czasie
10 Name:           python-pytest-freezegun
11 # keep 0.3.x here for python2 support
12 Version:        0.3.0.post1
13 Release:        1
14 License:        MIT
15 Group:          Libraries/Python
16 #Source0Download: https://pypi.org/simple/pytest-freezegun/
17 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-freezegun/pytest-freezegun-%{version}.zip
18 # Source0-md5:  2bf9d50fa0c78d20c193e7ded635bc2f
19 URL:            https://pypi.org/project/pytest-freezegun/
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-freezegun >= 0.3
25 BuildRequires:  python-pytest >= 3.0.0
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules >= 1:3.4
30 BuildRequires:  python3-setuptools
31 %if %{with tests}
32 BuildRequires:  python3-freezegun >= 0.3
33 BuildRequires:  python3-pytest >= 3.0.0
34 %endif
35 %endif
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.714
38 Requires:       python-modules >= 1:2.7
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Wrap tests with fixtures in freeze_time.
44
45 %description -l pl.UTF-8
46 Obudowywanie testów z wyposażeniem w czasie zamrożonym przez
47 freeze_time.
48
49 %package -n python3-pytest-freezegun
50 Summary:        Wrap tests with fixtures in freeze_time
51 Summary(pl.UTF-8):      Obudowywanie testów z wyposażeniem w zamrożonym czasie
52 Group:          Libraries/Python
53 Requires:       python3-modules >= 1:3.4
54
55 %description -n python3-pytest-freezegun
56 Wrap tests with fixtures in freeze_time.
57
58 %description -n python3-pytest-freezegun -l pl.UTF-8
59 Obudowywanie testów z wyposażeniem w czasie zamrożonym przez
60 freeze_time.
61
62 %prep
63 %setup -q -n pytest-freezegun-%{version}
64
65 %build
66 %if %{with python2}
67 %py_build
68 %endif
69
70 %if %{with python3}
71 %py3_build
72 %endif
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %if %{with python2}
78 %py_install
79
80 %py_postclean
81 %endif
82
83 %if %{with python3}
84 %py3_install
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %files
92 %defattr(644,root,root,755)
93 %doc LICENSE README.rst
94 %{py_sitescriptdir}/pytest_freezegun.py[co]
95 %{py_sitescriptdir}/pytest_freezegun-%{version}-py*.egg-info
96 %endif
97
98 %if %{with python3}
99 %files -n python3-pytest-freezegun
100 %defattr(644,root,root,755)
101 %doc LICENSE README.rst
102 %{py3_sitescriptdir}/pytest_freezegun.py
103 %{py3_sitescriptdir}/__pycache__/pytest_freezegun.cpython-*.py[co]
104 %{py3_sitescriptdir}/pytest_freezegun-%{version}-py*.egg-info
105 %endif
This page took 0.06084 seconds and 3 git commands to generate.