]> git.pld-linux.org Git - packages/python-pytest-forked.git/blob - python-pytest-forked.spec
199817a01e1548972e0cb84699063ae8c18ee41e
[packages/python-pytest-forked.git] / python-pytest-forked.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Run each test in a forked subprocess
8 Summary(pl.UTF-8):      Uruchamianie każdego testu w oddzielnym procesie
9 Name:           python-pytest-forked
10 Version:        1.1.3
11 Release:        2
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pytest-forked/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-forked/pytest-forked-%{version}.tar.gz
16 # Source0-md5:  7d507e84bf9d59182fd528f48fcae8cc
17 URL:            https://github.com/pytest-dev/pytest-forked
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 BuildRequires:  python-setuptools_scm
22 %if %{with tests}
23 BuildRequires:  python-pytest >= 3.1.0
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules >= 1:3.5
28 BuildRequires:  python3-setuptools
29 BuildRequires:  python3-setuptools_scm
30 %if %{with tests}
31 BuildRequires:  python3-pytest >= 3.1.0
32 %endif
33 %endif
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 Requires:       python-modules >= 1:2.7
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Run each test in a forked subprocess.
42
43 %description -l pl.UTF-8
44 Uruchamianie każdego testu w oddzielnym procesie.
45
46 %package -n python3-pytest-forked
47 Summary:        Run each test in a forked subprocess
48 Summary(pl.UTF-8):      Uruchamianie każdego testu w oddzielnym procesie
49 Group:          Libraries/Python
50 Requires:       python3-modules >= 1:3.5
51
52 %description -n python3-pytest-forked
53 Run each test in a forked subprocess.
54
55 %description -n python3-pytest-forked -l pl.UTF-8
56 Uruchamianie każdego testu w oddzielnym procesie.
57
58 %prep
59 %setup -q -n pytest-forked-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build
64
65 %if %{with tests}
66 # pytest-flaky plugin breaks test_functional_boxed_capturing
67 PYTHONPATH=$(pwd)/src \
68 %{__python} -m pytest -p no:flaky testing
69 %endif
70 %endif
71
72 %if %{with python3}
73 %py3_build
74
75 %if %{with tests}
76 PYTHONPATH=$(pwd)/src \
77 %{__python3} -m pytest -p no:flaky testing
78 %endif
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %if %{with python2}
85 %py_install
86
87 %py_postclean
88 %endif
89
90 %if %{with python3}
91 %py3_install
92 %endif
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %files
99 %defattr(644,root,root,755)
100 %doc CHANGELOG LICENSE README.rst example/boxed.txt
101 %{py_sitescriptdir}/pytest_forked
102 %{py_sitescriptdir}/pytest_forked-%{version}-py*.egg-info
103 %endif
104
105 %if %{with python3}
106 %files -n python3-pytest-forked
107 %defattr(644,root,root,755)
108 %doc CHANGELOG LICENSE README.rst example/boxed.txt
109 %{py3_sitescriptdir}/pytest_forked
110 %{py3_sitescriptdir}/pytest_forked-%{version}-py*.egg-info
111 %endif
This page took 0.115501 seconds and 2 git commands to generate.