]> git.pld-linux.org Git - packages/python-pytest-fixture-config.git/blob - python-pytest-fixture-config.spec
- up to 1.7.0
[packages/python-pytest-fixture-config.git] / python-pytest-fixture-config.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Fixture configuration utils for py.test
8 Summary(pl.UTF-8):      Narzędzia do konfiguracji osprzętu dla py.test
9 Name:           python-pytest-fixture-config
10 Version:        1.7.0
11 Release:        1
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/pytest-fixture-config/
15 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-fixture-config/pytest-fixture-config-%{version}.tar.gz
16 # Source0-md5:  ddfc66f7246535c2c238c72f3463b138
17 URL:            https://github.com/manahl/pytest-plugins
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 BuildRequires:  python-setuptools_git
24 %if %{with tests}
25 BuildRequires:  python-pytest
26 BuildRequires:  python-six
27 %endif
28 %endif
29 %if %{with python3}
30 BuildRequires:  python3-modules >= 1:3.4
31 BuildRequires:  python3-setuptools
32 BuildRequires:  python3-setuptools_git
33 %if %{with tests}
34 BuildRequires:  python-pytest
35 BuildRequires:  python-six
36 %endif
37 %endif
38 Requires:       python-modules >= 1:2.7
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Simple configuration objects for Py.test fixtures. Allows you to skip
44 tests when their required config variables aren't set.
45
46 %description -l pl.UTF-8
47 Proste obiekty konfiguracyjne do osprzętu (fixtures) Py.test.
48 Pozwalają pomijać testy, kiedy wymagane przez nie zmienne nie są
49 ustawione.
50
51 %package -n python3-pytest-fixture-config
52 Summary:        Fixture configuration utils for py.test
53 Summary(pl.UTF-8):      Narzędzia do konfiguracji osprzętu dla py.test
54 Group:          Libraries/Python
55 Requires:       python3-modules >= 1:3.4
56
57 %description -n python3-pytest-fixture-config
58 Simple configuration objects for Py.test fixtures. Allows you to skip
59 tests when their required config variables aren't set.
60
61 %description -n python3-pytest-fixture-config -l pl.UTF-8
62 Proste obiekty konfiguracyjne do osprzętu (fixtures) Py.test.
63 Pozwalają pomijać testy, kiedy wymagane przez nie zmienne nie są
64 ustawione.
65
66 %prep
67 %setup -q -n pytest-fixture-config-%{version}
68
69 %build
70 %if %{with python2}
71 %py_build %{?with_tests:test}
72 %endif
73
74 %if %{with python3}
75 %py3_build %{?with_tests:test}
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %py_install
83
84 %py_postclean
85 %endif
86
87 %if %{with python3}
88 %py3_install
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with python2}
95 %files
96 %defattr(644,root,root,755)
97 %doc CHANGES.md LICENSE README.md
98 %{py_sitescriptdir}/pytest_fixture_config.py[co]
99 %{py_sitescriptdir}/pytest_fixture_config-%{version}-py*.egg-info
100 %endif
101
102 %if %{with python3}
103 %files -n python3-pytest-fixture-config
104 %defattr(644,root,root,755)
105 %doc CHANGES.md LICENSE README.md
106 %{py3_sitescriptdir}/pytest_fixture_config.py
107 %{py3_sitescriptdir}/__pycache__/pytest_fixture_config.cpython-*.py[co]
108 %{py3_sitescriptdir}/pytest_fixture_config-%{version}-py*.egg-info
109 %endif
This page took 0.081986 seconds and 3 git commands to generate.