]> git.pld-linux.org Git - packages/python-pytest-expect.git/blob - python-pytest-expect.spec
f2ea472e80ec3a9901ac7b8f4f8e8b7cf1c30f8b
[packages/python-pytest-expect.git] / python-pytest-expect.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        py.test plugin to store test expectations and mark tests based on them
7 Summary(pl.UTF-8):      Wtyczka py.test do zapisywania oczekiwań testów oraz oznaczania testów w oparciu o nie
8 Name:           python-pytest-expect
9 Version:        1.1.0
10 Release:        5
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.python.org/simple/pytest-expect/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pytest-expect/pytest-expect-%{version}.tar.gz
15 # Source0-md5:  f74155c66f255364bf523d29e9bffe3e
16 URL:            https://github.com/tholo/pytest-expect
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.6
19 BuildRequires:  python-setuptools
20 %if %{with tests}
21 BuildRequires:  python-pytest
22 BuildRequires:  python-six
23 BuildRequires:  python-u-msgpack
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules >= 1:3.2
28 BuildRequires:  python3-setuptools
29 %if %{with tests}
30 BuildRequires:  python3-pytest
31 BuildRequires:  python3-six
32 BuildRequires:  python3-u-msgpack
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 Requires:       python-modules >= 1:2.6
38 BuildArch:      noarch
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 A py.test plugin that stores test expectations by saving the set of
43 failing tests, allowing them to be marked as xfail when running them
44 in future. The tests expectations are stored such that they can be
45 distributed alongside the tests.
46
47 %description -l pl.UTF-8
48 Wtyczka py.test zapisująca oczekiwania testów poprzez zapis zbioru
49 testów kończących się niepowodzeniem, pozwalając na zaznaczenie ich
50 jako xfail (spodziewane niepowodzenie) przy uruchamianiu w
51 przyszłości. Oczekiwania testów są zapisywane w taki sposób, że mogą
52 być rozprowadzane wraz z testami.
53
54 %package -n python3-pytest-expect
55 Summary:        py.test plugin to store test expectations and mark tests based on them
56 Summary(pl.UTF-8):      Wtyczka py.test do zapisywania oczekiwań testów oraz oznaczania testów w oparciu o nie
57 Group:          Libraries/Python
58 Requires:       python3-modules >= 1:3.2
59
60 %description -n python3-pytest-expect
61 A py.test plugin that stores test expectations by saving the set of
62 failing tests, allowing them to be marked as xfail when running them
63 in future. The tests expectations are stored such that they can be
64 distributed alongside the tests.
65
66 %description -n python3-pytest-expect -l pl.UTF-8
67 Wtyczka py.test zapisująca oczekiwania testów poprzez zapis zbioru
68 testów kończących się niepowodzeniem, pozwalając na zaznaczenie ich
69 jako xfail (spodziewane niepowodzenie) przy uruchamianiu w
70 przyszłości. Oczekiwania testów są zapisywane w taki sposób, że mogą
71 być rozprowadzane wraz z testami.
72
73 %prep
74 %setup -q -n pytest-expect-%{version}
75
76 %build
77 %if %{with python2}
78 %py_build
79 %endif
80
81 %if %{with python3}
82 %py3_build
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %py_install
90
91 %py_postclean
92 %endif
93
94 %if %{with python3}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc README.rst
105 %{py_sitescriptdir}/pytest_expect
106 %{py_sitescriptdir}/pytest_expect-%{version}-py*.egg-info
107 %endif
108
109 %if %{with python3}
110 %files -n python3-pytest-expect
111 %defattr(644,root,root,755)
112 %doc README.rst
113 %{py3_sitescriptdir}/pytest_expect
114 %{py3_sitescriptdir}/pytest_expect-%{version}-py*.egg-info
115 %endif
This page took 0.051669 seconds and 2 git commands to generate.