]> git.pld-linux.org Git - packages/python-pyrfc3339.git/blob - python-pyrfc3339.spec
- cleanup, pl
[packages/python-pyrfc3339.git] / python-pyrfc3339.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in sdist)
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Generate and parse RFC 3339 timestamps
8 Summary(pl.UTF-8):      Generowanie i analiza znaczników czasu RFC 3339
9 Name:           python-pyrfc3339
10 Version:        1.1
11 Release:        5
12 License:        MIT
13 #Source0Download: https://pypi.org/simple/pyRFC3339/
14 Source0:        https://files.pythonhosted.org/packages/source/p/pyRFC3339/pyRFC3339-%{version}.tar.gz
15 # Source0-md5:  c829980738b8271b0179ffd0c41187b0
16 Group:          Libraries/Python
17 URL:            https://pypi.org/project/pyRFC3339/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.7
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-nose
25 BuildRequires:  python-pytz
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules >= 1:3.4
30 BuildRequires:  python3-setuptools
31 %if %{with tests}
32 BuildRequires:  python3-nose
33 BuildRequires:  python3-pytz
34 %endif
35 %endif
36 BuildArch:      noarch
37
38 %description
39 This package contains a Python 2 library to parse and generate RFC
40 3339-compliant timestamps using Python datetime.datetime objects.
41
42 %description -l pl.UTF-8
43 Ten pakiet zawiera bibliotekę Pythona 2 do analizy i generowania
44 znaczników czasu zgodnych z RFC 3339 przy użyciu obiektów Pythona
45 datetime.datetime.
46
47 %package -n python3-pyrfc3339
48 Summary:        Generate and parse RFC 3339 timestamps
49 Summary(pl.UTF-8):      Generowanie i analiza znaczników czasu RFC 3339
50 Group:          Libraries/Python
51
52 %description -n python3-pyrfc3339
53 This package contains a Python 3 library to parse and generate RFC
54 3339-compliant timestamps using Python datetime.datetime objects.
55
56 %description -n python3-pyrfc3339 -l pl.UTF-8
57 Ten pakiet zawiera bibliotekę Pythona 2 do analizy i generowania
58 znaczników czasu zgodnych z RFC 3339 przy użyciu obiektów Pythona
59 datetime.datetime.
60
61 %prep
62 %setup -q -n pyRFC3339-%{version}
63
64 %build
65 %if %{with python2}
66 %py_build %{?with_tests:test}
67 %endif
68
69 %if %{with python3}
70 %py3_build %{?with_tests:test}
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %if %{with python2}
77 %py_install
78
79 %py_postclean
80 %endif
81
82 %if %{with python3}
83 %py3_install
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with python2}
90 %files
91 %defattr(644,root,root,755)
92 %doc README.rst LICENSE.txt
93 %{py_sitescriptdir}/pyrfc3339
94 %{py_sitescriptdir}/pyRFC3339-%{version}-py*.egg-info
95 %endif
96
97 %if %{with python3}
98 %files -n python3-pyrfc3339
99 %defattr(644,root,root,755)
100 %doc README.rst LICENSE.txt
101 %{py3_sitescriptdir}/pyrfc3339
102 %{py3_sitescriptdir}/pyRFC3339-%{version}-py*.egg-info
103 %endif
This page took 0.129848 seconds and 3 git commands to generate.