]> git.pld-linux.org Git - packages/python-pyrad.git/blob - python-pyrad.spec
- strict python deps, release 2
[packages/python-pyrad.git] / python-pyrad.spec
1
2 %define         module  pyrad
3
4 Summary:        pyrad - Python implementation of a RADIUS client
5 Summary(pl):    pyrad - implementacja klienta RADIUS w Pythonie
6 Name:           python-%{module}
7 Version:        0.8
8 Release:        2
9 License:        BSD-like
10 Group:          Libraries/Python
11 Source0:        http://www.wiggy.net/files/%{module}-%{version}.tar.gz
12 # Source0-md5:  562ddc819d5f6b9d6e1458483e8bbd26
13 URL:            http://www.wiggy.net/code/pyrad/
14 BuildRequires:  python-devel >= 1:2.3
15 %pyrequires_eq  python-libs
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 pyrad is an implementation of a RADIUS client as described in RFC2865.
21 It takes care of all the details like building RADIUS packets, sending
22 them and decoding responses.
23
24 %description -l pl
25 pyrad jest implementacj± klienta protoko³u RADIUS, opisanego w
26 dokumencie RFC2865. Modu³ ten odpowiada za wszystkie aspekty
27 przetwarzania protoko³u RADIUS, takie jak budowanie pakietów
28 protoko³u, wysy³anie ich oraz odkodowywanie odpowiedzi.
29
30 %package examples
31 Summary:        Example programs for Python pyrad module
32 Summary(pl):    Programy przyk³adowe do modu³u Pythona pyrad
33 Group:          Development/Languages/Python
34 Requires:       %{name} = %{version}-%{release}
35
36 %description examples
37 This package contains example programs for Python pyrad module.
38
39 %description examples -l pl
40 Pakiet zawieraj±cy programy przyk³adowe dla modu³u Pythona pyrad.
41
42 %prep
43 %setup -q -n %{module}-%{version}
44
45 %build
46 python setup.py build_ext
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_examplesdir}/%{name}-%{version}}
51
52 python setup.py install \
53         --root=$RPM_BUILD_ROOT \
54         --install-lib=%{py_sitescriptdir} \
55         --optimize=2
56
57 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
58
59 cp -ar example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README.txt
67 %{py_sitescriptdir}/pyrad
68
69 %files examples
70 %defattr(644,root,root,755)
71 %{_examplesdir}/%{name}-%{version}
This page took 0.032207 seconds and 3 git commands to generate.