]> git.pld-linux.org Git - packages/python-pyparsing.git/blob - python-pyparsing.spec
- strict python deps, release 2
[packages/python-pyparsing.git] / python-pyparsing.spec
1
2 %define         module  pyparsing
3
4 Summary:        pyparsing - a Python module for creating executing simple grammars
5 Summary(pl):    pyparsing - modu³ Pythona umo¿liwiaj±cy tworzenie i parsowanie prostych gramatyk
6 Name:           python-%{module}
7 Version:        1.2.2
8 Release:        2
9 License:        MIT
10 Group:          Libraries/Python
11 Source0:        http://dl.sourceforge.net/pyparsing/%{module}-%{version}.tar.gz
12 # Source0-md5:  700967c4c78e171783fae1073f74ea8d
13 URL:            http://pyparsing.sourceforge.net/
14 BuildRequires:  python-devel >= 1:2.3.2
15 BuildRequires:  python-modules
16 Requires:       python >= 2.3.2
17 %pyrequires_eq  python-libs
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The parsing module is an alternative approach to creating and
23 executing simple grammars, vs. the traditional lex/yacc approach, or
24 the use of regular expressions. The parsing module provides a library
25 of classes that client code uses to construct the grammar directly in
26 Python code.
27
28 %description -l pl
29 Modu³ pyparsing umo¿liwia tworzenie i parsowanie prostych gramatyk w
30 sposób odmienny od podej¶cia tradycyjnego, jakim jest zwykle u¿ycie
31 pary lex/yacc lub wyra¿eñ regularnych. Modu³ ten udostêpnia bibliotekê
32 klas, przy pomocy których gramatyka tworzona jest wprost w kodzie
33 Pythona.
34
35 %package doc
36 Summary:        Documentation for pyparsing module
37 Summary(pl):    Dokumentacja do modu³u pyparsing
38 Group:          Libraries/Python
39 Requires:       %{name} = %{version}-%{release}
40
41 %description doc
42 This package contains documentation files for pyparsing Python module.
43
44 %description doc -l pl
45 Pakiet zawieraj±cy dokumentacjê dla modu³u Pythona pyparsing.
46
47 %package examples
48 Summary:        Examples for pyparsing module
49 Summary(pl):    Przyk³ady do modu³u pyparsing
50 Group:          Libraries/Python
51 Requires:       %{name} = %{version}-%{release}
52
53 %description examples
54 This package contains example files for pyparsing Python module.
55
56 %description examples -l pl
57 Pakiet zawieraj±cy przyk³adowe skrypty dla modu³u Pythona pyparsing.
58
59 %prep
60 %setup -q -n %{module}-%{version}
61
62 %build
63 python setup.py build_ext
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{py_sitescriptdir},%{_examplesdir}/%{name}-%{version}}
68
69 python setup.py install \
70         --root=$RPM_BUILD_ROOT \
71         --install-lib=%{py_sitescriptdir} \
72         --optimize=2
73
74 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
75
76 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc CHANGES README
84 %{py_sitescriptdir}/pyparsing.py[oc]
85
86 %files doc
87 %defattr(644,root,root,755)
88 %doc HowToUsePyparsing.html htmldoc pyparsingClassDiagram.{JPG,PNG}
89
90 %files examples
91 %defattr(644,root,root,755)
92 %{_examplesdir}/%{name}-%{version}
This page took 0.03031 seconds and 3 git commands to generate.