]> git.pld-linux.org Git - packages/python-pyinotify.git/blob - python-pyinotify.spec
d0704ab137100af9b938ed004d8a8103dcdb3da0
[packages/python-pyinotify.git] / python-pyinotify.spec
1 %define         module  pyinotify
2 Summary:        Pyinotify is a pure Python module used for monitoring filesystems changes
3 Summary(hu.UTF-8):      Pyinotify egy egyszerű Python modul, amellyel a fájlrendszer változásait lehet figyelni
4 Name:           python-%{module}
5 Version:        0.9.4
6 Release:        1
7 License:        GPL v2
8 Group:          Development/Languages/Python
9 Source0:        http://seb.dbzteam.org/pub/pyinotify/releases/%{module}-%{version}.tar.gz
10 # Source0-md5:  701c91854d241514ede7ffe72086566d
11 URL:            https://github.com/seb-m/pyinotify
12 BuildRequires:  python-devel
13 BuildRequires:  python3-modules
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 Requires:       glibc >= 2.4
17 Requires:       python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Pyinotify is a pure Python module used for monitoring filesystems
22 changes.
23
24 %description -l hu.UTF-8
25 Pyinotify egy egyszerű Python modul, amellyel a fájlrendszer
26 változásait lehet figyelni.
27
28 %package -n     python3-%{module}
29 Summary:        Pyinotify is a pure Python module used for monitoring filesystems changes
30 Version:        %{version}
31 Release:        %{release}
32 Group:          Development/Languages/Python
33
34 %description -n python3-%{module}
35 Pyinotify is a pure Python module used for monitoring filesystems
36 changes.
37
38 %description -n python3-%{module} -l hu.UTF-8
39 Pyinotify egy egyszerű Python modul, amellyel a fájlrendszer
40 változásait lehet figyelni.
41
42 %prep
43 %setup -q -n %{module}-%{version}
44
45 %build
46 export CFLAGS="%{rpmcflags}"
47 %{__python} setup.py build -b build_python2
48 %{__python3} setup.py build -b build_python3
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53 mv build_python2 build
54 %{__python} setup.py install \
55         --optimize=2 \
56         --root=$RPM_BUILD_ROOT
57
58 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
59 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
60 %py_postclean
61
62 install python2/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %{__rm} -r build
65 mv build_python3 build
66 %{__python3} setup.py \
67         install \
68         --root=$RPM_BUILD_ROOT \
69         --optimize=2
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc old/ChangeLog old/NEWS README.md
77 %{_examplesdir}/%{name}-%{version}
78 %{py_sitescriptdir}/*.py[co]
79 %{py_sitescriptdir}/%{module}-*.egg-info
80
81 %files -n python3-%{module}
82 %defattr(644,root,root,755)
83 %{py3_sitescriptdir}/%{module}*.py
84 %{py3_sitescriptdir}/__pycache__
85 %{py3_sitescriptdir}/%{module}-*.egg-info
This page took 0.10307 seconds and 2 git commands to generate.