]> git.pld-linux.org Git - packages/python-pyinotify.git/blob - python-pyinotify.spec
- release 2 (by relup.sh)
[packages/python-pyinotify.git] / python-pyinotify.spec
1 %define         module  pyinotify
2 Summary:        Pyinotify - pure Python module used for monitoring filesystems changes
3 Summary(hu.UTF-8):      Pyinotify egy egyszerű Python modul, amellyel a fájlrendszer változásait lehet figyelni
4 Summary(pl.UTF-8):      Pyinotify - moduł w czystym Pythonie do monitorowania zmian w systemie plików
5 Name:           python-%{module}
6 Version:        0.9.6
7 Release:        2
8 License:        MIT
9 Group:          Development/Languages/Python
10 Source0:        http://seb.dbzteam.org/pub/pyinotify/releases/%{module}-%{version}.tar.gz
11 # Source0-md5:  8e580fa1ff3971f94a6f81672b76c406
12 URL:            https://github.com/seb-m/pyinotify
13 BuildRequires:  python-devel
14 BuildRequires:  python-setuptools
15 BuildRequires:  python3-modules
16 BuildRequires:  python3-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 Requires:       glibc >= 2.4
20 Requires:       python-modules
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Pyinotify is a pure Python module used for monitoring filesystems
26 changes.
27
28 %description -l hu.UTF-8
29 Pyinotify egy egyszerű Python modul, amellyel a fájlrendszer
30 változásait lehet figyelni.
31
32 %description -l pl.UTF-8
33 Pyinotify to moduł w czystym Pythonie służący do monitorowania zmian w
34 systemie plików.
35
36 %package -n python3-%{module}
37 Summary:        Pyinotify is a pure Python module used for monitoring filesystems changes
38 Summary(pl.UTF-8):      Pyinotify - moduł w czystym Pythonie do monitorowania zmian w systemie plików
39 Group:          Development/Languages/Python
40
41 %description -n python3-%{module}
42 Pyinotify is a pure Python module used for monitoring filesystems
43 changes.
44
45 %description -n python3-%{module} -l hu.UTF-8
46 Pyinotify egy egyszerű Python modul, amellyel a fájlrendszer
47 változásait lehet figyelni.
48
49 %description -n python3-%{module} -l pl.UTF-8
50 Pyinotify to moduł w czystym Pythonie służący do monitorowania zmian w
51 systemie plików.
52
53 %prep
54 %setup -q -n %{module}-%{version}
55
56 %build
57 export CFLAGS="%{rpmcflags}"
58 %{__python} setup.py build -b build_python2
59 %{__python3} setup.py build -b build_python3
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 mv build_python2 build
65 %{__python} setup.py install \
66         --optimize=2 \
67         --root=$RPM_BUILD_ROOT
68
69 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
70 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
71 %py_postclean
72
73 install python2/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74
75 %{__rm} -r build
76 mv build_python3 build
77 %{__python3} setup.py \
78         install \
79         --root=$RPM_BUILD_ROOT \
80         --optimize=2
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc old/ChangeLog old/NEWS README.md
88 %{py_sitescriptdir}/pyinotify.py[co]
89 %{py_sitescriptdir}/pyinotify-%{version}-py*.egg-info
90 %{_examplesdir}/%{name}-%{version}
91
92 %files -n python3-%{module}
93 %defattr(644,root,root,755)
94 %{py3_sitescriptdir}/pyinotify.py
95 %{py3_sitescriptdir}/__pycache__
96 %{py3_sitescriptdir}/pyinotify-%{version}-py*.egg-info
This page took 0.064348 seconds and 3 git commands to generate.