]> git.pld-linux.org Git - packages/python3-pygments.git/blob - python-pygments.spec
- based on sphinx-pdg.spec
[packages/python3-pygments.git] / python-pygments.spec
1
2 %define module pygments
3 Summary:        Generic syntax highlighter
4 Name:           python-%{module}
5 Version:        0.11.1
6 Release:        1
7 License:        BSD
8 Group:          Development/Languages/Python
9 Source0:        http://pypi.python.org/packages/source/P/Pygments/Pygments-%{version}.tar.gz
10 # Source0-md5:  a7dc555f316437ba5241855ac306209a
11 URL:            http://jinja.pocoo.org/1/
12 BuildRequires:  python-devel
13 %pyrequires_eq  python-modules
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Pygments is a generic syntax highlighter for general use in all kinds of
19 software such as forum systems, wikis or other applications that need to
20 prettify source code. Highlights are
21 - a wide range of common languages and markup formats is supported
22 - special attention is paid to details that increase highlighting quality
23 - support for new languages and formats are added easily; most languages
24   use a simple regex-based lexing mechanism
25 - a number of output formats is available, among them HTML, RTF, LaTeX and
26   ANSI sequences
27 - it is usable as a command-line tool and as a library
28 - ... and it highlights even Brainf*ck!
29
30 %prep
31 %setup -q -n Pygments-%{version}
32
33 %build
34 %{__python} setup.py build
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 %{__python} setup.py install \
40                 --optimize=2 \
41                 --root=$RPM_BUILD_ROOT
42
43 %py_postclean
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc PKG-INFO TODO AUTHORS
51 %attr(755,root,root) %{_bindir}/*
52 %{py_sitescriptdir}/%{module}
53 %{py_sitescriptdir}/*Pygments*.egg*
This page took 0.041725 seconds and 4 git commands to generate.