]> git.pld-linux.org Git - packages/python-pygame.git/blob - python-pygame.spec
- fix building on x32
[packages/python-pygame.git] / python-pygame.spec
1 #
2 # TODO: - unpackaged files:
3 #               _site-packages/pygame/docs/*
4 #               _site-packages/pygame/examples/*
5 #               _site-packages/pygame/gp2x/*
6 #               _site-packages/pygame/tests/*
7 #
8
9 %define         module  pygame
10
11 Summary:        Python modules designed for writing games
12 Summary(pl.UTF-8):      Moduły Pythona dla piszących gry
13 Name:           python-%{module}
14 Version:        1.9.1
15 Release:        15
16 License:        LGPL v2.1+
17 Group:          Libraries/Python
18 Source0:        http://www.pygame.org/ftp/pygame-%{version}release.tar.gz
19 # Source0-md5:  1c4cdc708d17c8250a2d78ef997222fc
20 Patch0:         %{name}-porttime.patch
21 Patch1:         %{name}-remove-v4l.patch
22 Patch2:         x32.patch
23 URL:            http://www.pygame.org/
24 BuildRequires:  SDL-devel
25 BuildRequires:  SDL_image-devel
26 BuildRequires:  SDL_mixer-devel
27 BuildRequires:  SDL_ttf-devel >= 2.0
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  portmidi-devel >= 217
31 BuildRequires:  python-numpy-devel
32 BuildRequires:  python-devel >= 2.2.1
33 BuildRequires:  python-modules
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.219
36 BuildRequires:  smpeg-devel
37 %pyrequires_eq  python
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Pygame is a set of Python modules designed for writing games. It is
42 written on top of the excellent SDL library. This allows you to create
43 fully featured games and multimedia programs in the python language.
44 The package is highly portable, with games running on Windows, NT4,
45 MacOS, OSX, BeOS, FreeBSD, IRIX, and Linux.
46
47 %description -l pl.UTF-8
48 Pygame jest zbiorem modułów Pythona zaprojektowanych do pisania gier.
49 Moduły te zostały napisane na bazie wspaniałej biblioteki SDL. Dzięki
50 temu możliwe jest tworzenie bogatych w multimedia gier w języku
51 Python.
52
53 %package devel
54 Summary:        C header files for pygame modules
55 Summary(pl.UTF-8):      Pliki nagłówkowe języka C modułów pygame
56 Group:          Development/Languages/Python
57 %pyrequires_eq  python
58 Requires:       %{name} = %{version}-%{release}
59
60 %description devel
61 C header files for pygame modules.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe języka C modułów pygame.
65
66 %prep
67 %setup -q -n %{module}-%{version}release
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71
72 %build
73 CFLAGS="%{rpmcflags} -I/usr/include/smpeg"; export CFLAGS
74 python setup.py build
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 python setup.py install \
81         --root=$RPM_BUILD_ROOT
82
83 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
86 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
87 %py_postclean
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc WHATSNEW docs/*
95 %dir %{py_sitedir}/%{module}
96 %{py_sitedir}/%{module}/*.ttf
97 %attr(755,root,root) %{py_sitedir}/%{module}/*.so
98 %{py_sitedir}/%{module}/*.py[co]
99 %dir %{py_sitedir}/%{module}/threads/
100 %{py_sitedir}/%{module}/threads/*.py[co]
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{py_incdir}/%{module}
105 %{_examplesdir}/%{name}-%{version}
This page took 0.094744 seconds and 3 git commands to generate.