]> git.pld-linux.org Git - packages/python-pyflakes.git/blob - python-pyflakes.spec
9205bd5bddcf816efbec017e59b6851f58b8dd9a
[packages/python-pyflakes.git] / python-pyflakes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # test target
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  pyflakes
8 Summary:        Passive checker of Python programs
9 Summary(pl.UTF-8):      Pasywny program do sprawdzania programów w Pythonie
10 Name:           python-%{module}
11 # NOTE: before upgrading to >=2.4.0 check for python2-compatible flake8 release supporting new pyflakes
12 Version:        2.3.1
13 Release:        1
14 License:        MIT
15 Group:          Development/Tools
16 #Source0Download: https://pypi.org/simple/pyflakes/
17 Source0:        https://files.pythonhosted.org/packages/source/p/pyflakes/%{module}-%{version}.tar.gz
18 # Source0-md5:  0b60a307a6b293ee505fe0134e9d46e9
19 URL:            https://github.com/PyCQA/pyflakes
20 %if %{with python2}
21 BuildRequires:  python-devel >= 1:2.7
22 BuildRequires:  python-modules >= 1:2.7
23 BuildRequires:  python-setuptools
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-devel >= 1:3.4
27 BuildRequires:  python3-modules >= 1:3.4
28 BuildRequires:  python3-setuptools
29 %endif
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.714
32 Requires:       python-modules >= 1:2.7
33 Provides:       pyflakes = %{version}-%{release}
34 Obsoletes:      pyflakes < 0.4.0-2
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Pyflakes is a simple program which checks Python source files for
40 errors. It is similar to PyChecker in scope, but differs in that it
41 does not execute the modules to check them. This is both safer and
42 faster, although it does not perform as many checks. Unlike PyLint,
43 Pyflakes checks only for logical errors in programs; it does not
44 perform any checks on style.
45
46 %description -l pl.UTF-8
47 Pyflakes to prosty program sprawdzający pliki źródłowe Pythona pod
48 kątem błędów. Jest podobny do PyCheckera jeśli chodzi o zakres
49 działania, ale różni się tym, że nie wykonuje modułów przy sprawdzaniu
50 ich. Jest to zarówno bardziej bezpieczne, jak i szybze, choć nie
51 sprawdza tak wielu rzeczy. W przeciwieństwie do PyLinta Pyflakes szuka
52 tylko błędów logicznych w programach; nie sprawdza stylu.
53
54 %package -n python3-%{module}
55 Summary:        Passive checker of Python programs
56 Summary(pl.UTF-8):      Pasywny program do sprawdzania programów w Pythonie
57 Group:          Libraries/Python
58 Requires:       python3-modules >= 1:3.4
59 # default binary moved
60 Conflicts:      python-pyflakes < 2.1.1-4
61
62 %description -n python3-%{module}
63 Pyflakes is a simple program which checks Python source files for
64 errors. It is similar to PyChecker in scope, but differs in that it
65 does not execute the modules to check them. This is both safer and
66 faster, although it does not perform as many checks. Unlike PyLint,
67 Pyflakes checks only for logical errors in programs; it does not
68 perform any checks on style.
69
70 %description -n python3-%{module} -l pl.UTF-8
71 Pyflakes to prosty program sprawdzający pliki źródłowe Pythona pod
72 kątem błędów. Jest podobny do PyCheckera jeśli chodzi o zakres
73 działania, ale różni się tym, że nie wykonuje modułów przy sprawdzaniu
74 ich. Jest to zarówno bardziej bezpieczne, jak i szybze, choć nie
75 sprawdza tak wielu rzeczy. W przeciwieństwie do PyLinta Pyflakes szuka
76 tylko błędów logicznych w programach; nie sprawdza stylu.
77
78 %prep
79 %setup -q -n %{module}-%{version}
80
81 %build
82 %if %{with python2}
83 %py_build
84
85 %if %{with tests}
86 %{__python} -m unittest discover -s pyflakes/test
87 %endif
88 %endif
89
90 %if %{with python3}
91 %py3_build
92
93 %if %{with tests}
94 %{__python3} -m unittest discover -s pyflakes/test
95 %endif
96 %endif
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %py_install
103
104 %{__mv} $RPM_BUILD_ROOT%{_bindir}/pyflakes{,-2}
105
106 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/pyflakes/test
107 %py_postclean
108 %endif
109
110 %if %{with python3}
111 %py3_install
112
113 %{__mv} $RPM_BUILD_ROOT%{_bindir}/pyflakes{,-3}
114 ln -sf pyflakes-3 $RPM_BUILD_ROOT%{_bindir}/pyflakes
115
116 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/pyflakes/test
117 %endif
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %if %{with python2}
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS LICENSE NEWS.rst README.rst
126 %attr(755,root,root) %{_bindir}/pyflakes-2
127 %{py_sitescriptdir}/pyflakes
128 %{py_sitescriptdir}/pyflakes-%{version}-py*.egg-info
129 %endif
130
131 %if %{with python3}
132 %files -n python3-%{module}
133 %defattr(644,root,root,755)
134 %doc AUTHORS LICENSE NEWS.rst README.rst
135 %attr(755,root,root) %{_bindir}/pyflakes
136 %attr(755,root,root) %{_bindir}/pyflakes-3
137 %{py3_sitescriptdir}/pyflakes
138 %{py3_sitescriptdir}/pyflakes-%{version}-py*.egg-info
139 %endif
This page took 0.079168 seconds and 2 git commands to generate.