]> git.pld-linux.org Git - packages/python-pyflakes.git/blob - python-pyflakes.spec
- release 2 (by relup.sh)
[packages/python-pyflakes.git] / python-pyflakes.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  pyflakes
8 Summary:        Passive checker of Python programs
9 Summary(pl.UTF-8):      Pasywny program do sprawdzania programów w Pythonie
10 Name:           python-%{module}
11 Version:        0.9.2
12 Release:        2
13 License:        MIT
14 Group:          Development/Tools
15 Source0:        http://pypi.python.org/packages/source/p/pyflakes/%{module}-%{version}.tar.gz
16 # Source0-md5:  f7032897353e68f6dc6210dfab39f414
17 URL:            http://www.divmod.org/projects/pyflakes
18 %if %{with python2}
19 BuildRequires:  python-devel
20 Requires:       python-modules
21 %endif
22
23 %{?with_tests:BuildRequires:    rpm-pythonprov}
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 %if %{with python3}
26 BuildRequires:  python3-devel
27 BuildRequires:  python3-modules
28 %endif
29 Provides:       pyflakes = %{version}-%{release}
30 Obsoletes:      pyflakes < 0.4.0-2
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Pyflakes is a simple program which checks Python source files for
36 errors. It is similar to PyChecker in scope, but differs in that it
37 does not execute the modules to check them. This is both safer and
38 faster, although it does not perform as many checks. Unlike PyLint,
39 Pyflakes checks only for logical errors in programs; it does not
40 perform any checks on style.
41
42 %description -l pl.UTF-8
43 Pyflakes to prosty program sprawdzający pliki źródłowe Pythona pod
44 kątem błędów. Jest podobny do PyCheckera jeśli chodzi o zakres
45 działania, ale różni się tym, że nie wykonuje modułów przy sprawdzaniu
46 ich. Jest to zarówno bardziej bezpieczne, jak i szybze, choć nie
47 sprawdza tak wielu rzeczy. W przeciwieństwie do PyLinta Pyflakes szuka
48 tylko błędów logicznych w programach; nie sprawdza stylu.
49
50 %package -n python3-%{module}
51 Summary:        Passive checker of Python programs
52 Summary(pl.UTF-8):      Pasywny program do sprawdzania programów w Pythonie
53 Group:          Libraries/Python
54 Requires:       python3-modules
55
56 %description -n python3-%{module}
57 Pyflakes is a simple program which checks Python source files for
58 errors. It is similar to PyChecker in scope, but differs in that it
59 does not execute the modules to check them. This is both safer and
60 faster, although it does not perform as many checks. Unlike PyLint,
61 Pyflakes checks only for logical errors in programs; it does not
62 perform any checks on style.
63
64 %description -n python3-%{module} -l pl.UTF-8
65 Pyflakes to prosty program sprawdzający pliki źródłowe Pythona pod
66 kątem błędów. Jest podobny do PyCheckera jeśli chodzi o zakres
67 działania, ale różni się tym, że nie wykonuje modułów przy sprawdzaniu
68 ich. Jest to zarówno bardziej bezpieczne, jak i szybze, choć nie
69 sprawdza tak wielu rzeczy. W przeciwieństwie do PyLinta Pyflakes szuka
70 tylko błędów logicznych w programach; nie sprawdza stylu.
71
72 %prep
73 %setup -q -n %{module}-%{version}
74
75 %build
76 %if %{with python2}
77 CC="%{__cc}" \
78 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
79 %py_build %{?with_tests:test}
80 %endif
81
82 %if %{with python3}
83 CC="%{__cc}" \
84 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
85 %py3_build %{?with_tests:test}
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{with python2}
92 %py_install
93
94 %py_postclean
95 %endif
96
97 %if %{with python3}
98 %py3_install
99 %endif
100
101 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/pyflakes/test
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %if %{with python2}
107 %files
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/pyflakes
110 %{py_sitescriptdir}/pyflakes
111 %if "%{py_ver}" > "2.4"
112 %{py_sitescriptdir}/pyflakes-%{version}-*.egg-info
113 %endif
114 %endif
115
116 %if %{with python3}
117 %files -n python3-%{module}
118 %defattr(644,root,root,755)
119 %{py3_sitescriptdir}/%{module}
120 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
121 %endif
This page took 0.054575 seconds and 3 git commands to generate.