]> git.pld-linux.org Git - packages/python-pyevent.git/blob - python-pyevent.spec
- fixed building with libevent 2.1
[packages/python-pyevent.git] / python-pyevent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  pyevent
6
7 Summary:        Python extension module for libevent
8 Summary(pl.UTF-8):      Moduł rozszerzenia Pythona dla biblioteki libevent
9 Name:           python-%{module}
10 Version:        0.3
11 Release:        11
12 License:        MIT
13 Group:          Libraries/Python
14 Source0:        http://pyevent.googlecode.com/files/%{module}-%{version}.tar.gz
15 # Source0-md5:  584912c92d08bf005283fb29a47a6e4d
16 Patch0:         %{name}-python25.patch
17 Patch1:         %{name}-setup.patch
18 Patch2:         libevent-2.1.patch
19 Patch3:         test-path.patch
20 URL:            http://code.google.com/p/pyevent/
21 BuildRequires:  rpmbuild(macros) >= 1.710
22 BuildRequires:  libevent-devel
23 BuildRequires:  python-devel >= 1:2.5
24 BuildRequires:  python-modules
25 BuildRequires:  rpm-pythonprov
26 %pyrequires_eq  python-libs
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Python extension module for libevent.
31
32 %description -l pl.UTF-8
33 Moduł rozszerzenia Pythona dla biblioteki libevent.
34
35 %prep
36 %setup -q -n %{module}-%{version}
37 %patch0 -p1
38 %patch1 -p1
39 %patch2 -p1
40 %patch3 -p1
41
42 %build
43 pyrexc event.pyx
44 %py_build
45 %{?with_tests:./test.py}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %py_install
51
52 %py_postclean
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES README
60 %attr(755,root,root) %{py_sitedir}/event.so
61 %{py_sitedir}/event-*.egg-info
This page took 0.06743 seconds and 3 git commands to generate.