]> git.pld-linux.org Git - packages/python-pycvs.git/blob - python-pycvs.spec
- created, adapterized
[packages/python-pycvs.git] / python-pycvs.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         module pycvs
4
5 Summary:        CVS support for python
6 Summary(pl):    Obs³uga CVSu dla pythona
7 Name:           python-%{module}
8 Version:        0.1
9 Release:        1
10 License:        GNU
11 Group:          Development/Languages/Python
12 Source0:        http://dl.sourceforge.net/pycvs/%{module}-%{version}.tar.gz
13 # Source0-md5:  3abf7c9d6d67a760190692071a476edc
14 URL:            http://pycvs.sourceforge.net/
15 %pyrequires_eq  python-modules
16 BuildRequires:  python-devel >= 2.3
17 BuildRequires:  rpm-pythonprov
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 pyCVS is a python library/module for the CVS (Concurrent Versions
22 System) protocol. It supports asynchronous and synchronous handling of
23 CVS servers.
24
25 %description -l pl
26 pyCVS jest bibliotek±/modu³em pythona do obs³ugi protoko³u CVS
27 (Concurrent Versions System). Obs³uguje asynchroniczn± i synchroniczn±
28 obs³ugê serwerów CVS.
29
30 %prep
31 %setup -q -n %{module}-%{version}
32
33 %build
34 python -c "import compiler;compiler.compileFile('library/pycvs.py')"
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{py_sitedir}
39 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
40 install clients/client.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
41 install library/pycvs.pyc $RPM_BUILD_ROOT%{py_sitedir}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc AUTHORS README
49 %{py_sitedir}/*.py[co]
50 %dir %{_examplesdir}/%{name}-%{version}
51 %{_examplesdir}/%{name}-%{version}/*
This page took 0.0388 seconds and 4 git commands to generate.