]> git.pld-linux.org Git - packages/python-pycoin.git/blob - python-pycoin.spec
Release 14 (by relup.sh)
[packages/python-pycoin.git] / python-pycoin.spec
1 #
2 # Conditional build:
3 %bcond_without  python2         # Python 2.x module
4 %bcond_without  python3         # Python 3.x module
5
6 %define         module  pycoin
7 Summary:        Bitcoin utility library
8 Summary(pl.UTF-8):      Biblioteka narzędziowa Bitcoin
9 Name:           python-pycoin
10 Version:        0.24
11 Release:        14
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://github.com/richardkiss/pycoin/releases
15 #TODO: use      https://github.com/richardkiss/pycoin/archive/%{version}/pycoin-%{version}.tar.gz
16 Source0:        https://github.com/richardkiss/pycoin/archive/%{version}.tar.gz
17 # Source0-md5:  512f17827323eb1ba2bfe7952829575d
18 URL:            https://github.com/richardkiss/pycoin
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 BuildRequires:  rpm-pythonprov
21 %if %{with python2}
22 BuildRequires:  python-devel
23 BuildRequires:  python-modules
24 BuildRequires:  python-setuptools
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-2to3
28 BuildRequires:  python3-devel
29 BuildRequires:  python3-modules
30 BuildRequires:  python3-setuptools
31 %endif
32 Requires:       python-modules
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This is an implementation of a bunch of utility routines that may be
38 useful when dealing with Bitcoin stuff.
39
40 %description -l pl.UTF-8
41 Implementacja zbioru funkcji narzędziowych, które mogą być przydatne
42 przy operowaniu na Bitcoinach.
43
44 %package -n python3-%{module}
45 Summary:        Bitcoin utility library
46 Summary(pl.UTF-8):      Biblioteka narzędziowa Bitcoin
47 Group:          Libraries/Python
48 Requires:       python3-modules
49
50 %description -n python3-%{module}
51 This is an implementation of a bunch of utility routines that may be
52 useful when dealing with Bitcoin stuff.
53
54 %description -n python3-%{module} -l pl.UTF-8
55 Implementacja zbioru funkcji narzędziowych, które mogą być przydatne
56 przy operowaniu na Bitcoinach.
57
58 %package -n %{module}
59 Summary:        Bitcoin utility library - tools
60 Summary(pl.UTF-8):      Biblioteka narzędziowa Bitcoin - narzędzia
61 Group:          Libraries/Python
62 Requires:       python%{?with_python3:3}
63 Requires:       python%{?with_python3:3}-%{module} = %{version}-%{release}
64 Requires:       python%{?with_python3:3}-distribute
65
66 %description -n %{module}
67 Tools that use pycoin library.
68
69 %description -n %{module} -l pl.UTF-8
70 Narzędzia wykorzystująca bibliotekę pycoin.
71
72 %prep
73 %setup  -q -n pycoin-%{version}
74
75 %build
76 %if %{with python2}
77 %py_build
78 %endif
79
80 %if %{with python3}
81 %py3_build
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with python2}
88 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{module}-%{version}
89 %py_install
90 %endif
91
92 %if %{with python3}
93 install -d $RPM_BUILD_ROOT%{_examplesdir}/python3-%{module}-%{version}
94 %py3_install
95 %endif
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %if %{with python2}
101 %files
102 %defattr(644,root,root,755)
103 %doc CHANGES CREDITS README.md
104 %{py_sitescriptdir}/%{module}
105 %{py_sitescriptdir}/*egg-info
106 %{_examplesdir}/python-%{module}-%{version}
107 %endif
108
109 %if %{with python3}
110 %files -n python3-%{module}
111 %defattr(644,root,root,755)
112 %doc CHANGES CREDITS README.md
113 %{py3_sitescriptdir}/%{module}
114 %{py3_sitescriptdir}/*egg-info
115 %{_examplesdir}/python3-%{module}-%{version}
116 %endif
117
118 %files -n %{module}
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/bu
121 %attr(755,root,root) %{_bindir}/genwallet
122 %attr(755,root,root) %{_bindir}/spend
This page took 0.069549 seconds and 3 git commands to generate.