]> git.pld-linux.org Git - packages/python-pycassa.git/blob - python-pycassa.spec
45d0781e2483e0be1d447a5a2f42bfd63043adbf
[packages/python-pycassa.git] / python-pycassa.spec
1 %define         module  pycassa
2 Summary:        Simple Python Cassandra library
3 Summary(pl.UTF-8):      Prosta biblioteka Pythona do Cassandry
4 Name:           python-%{module}
5 Version:        1.11.1
6 Release:        4
7 License:        MIT/apache
8 Group:          Development/Languages/Python
9 # https://github.com/downloads/pycassa/pycassa/pycassa-1.0.1.tar.gz
10 # https://github.com/%{module}/%{module}/archive/v%{version}.tar.gz
11 Source0:        https://github.com/%{module}/%{module}/archive/v%{version}.tar.gz
12 # Source0-md5:  b87e4effd85384fde09f016b0b084039
13 URL:            https://github.com/pycassa/pycassa
14 BuildRequires:  python-devel
15 BuildRequires:  python-setuptools >= 1:0.6-2.c11
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 Requires:       python-modules
19 Requires:       python-thrift
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Cassandra library with the following features: auto-failover single or
25 thread-local connections, a simplified version of the thrift
26 interface, a method to map an existing class to a Cassandra
27 ColumnFamily. Supports SuperColumns.
28
29 %description -l pl.UTF-8
30 Biblioteka dostępu do Cassandry dla Pythona posiadająca: Jednowątkowy
31 lub wielowątkowy interfejs, uproszczona wersję interfejsu thrift,
32 metody do mapowania klas w ColumnFamily Cassandry. Wspiera obsługę
33 superkolumn.
34
35
36 %prep
37 %setup -q -n %{module}-%{version}
38
39 %build
40 %py_build
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 %py_install
45
46 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
47 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %attr(755,root,root) %{_bindir}/pycassaShell
56
57 %{py_sitescriptdir}/ez_setup.py[co]
58
59 %dir %{py_sitescriptdir}/%{module}
60 %{py_sitescriptdir}/%{module}/*.py[co]
61 %dir %{py_sitescriptdir}/%{module}/cassandra
62 %{py_sitescriptdir}/%{module}/cassandra/*.py[co]
63 %dir %{py_sitescriptdir}/%{module}/logging
64 %{py_sitescriptdir}/%{module}/logging/*.py[co]
65 %dir %{py_sitescriptdir}/%{module}/contrib
66 %{py_sitescriptdir}/%{module}/contrib/*.py[co]
67
68
69 %if "%{py_ver}" > "2.4"
70 %{py_sitescriptdir}/%{module}-*.egg-info
71 %endif
This page took 0.062816 seconds and 2 git commands to generate.